Modify

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#3016 closed defect (duplicate)

License definition in setup.py causes "python setup.py bdist_rpm" to fail

Reported by: robin-trac-hacks@… Owned by: mgood
Priority: normal Component: AccountManagerPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

Your rather interesting "BEER-WARE" license breaks "python setup.py bdist_rpm".

Replacing it with "license = 'BSD'," fixes the problem

Attachments (0)

Change History (5)

comment:1 Changed 6 years ago by anonymous

  • Component changed from TracHacks to AccountManagerPlugin
  • Owner changed from athomas to mgood

comment:2 Changed 6 years ago by pacopablo

  • Resolution set to duplicate
  • Status changed from new to closed

duplicate of #1953

Also, BSD is not the same as BEER-WARE

comment:3 Changed 6 years ago by robin-trac-hacks@…

Hmmm, not sure what the problem is, but it now seems to build OK with:

license = 'THE BEER-WARE LICENSE',

Sorry for the noise.

comment:4 Changed 6 years ago by pacopablo

This should be fixed as of [3721] also

comment:5 Changed 6 years ago by robin-trac-hacks@…

Ah, that's what changed!

Thanks.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from mgood. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.