Modify

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#307 closed defect (invalid)

Links attached to tags don't work

Reported by: perus@… Owned by: pacopablo
Priority: normal Component: TracBlogPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.10

Description

In a Blog post, or in the Tag index page, the links attached to a tag created by BlogPlugin are framed by '%27' and don't work.

Noticed with Safari 2.0.3 and Firefox 1.5.0.1 on MacOS 10.4.6

Attachments (0)

Change History (5)

comment:1 Changed 8 years ago by pacopablo

  • Status changed from new to assigned

Um, I'm not exactly sure what you're referring to.

Are you saying that the links in /tags don't work?

I've tried replicating this, but I can't. Can you give instructions on how to duplicate? Or perhaps a link to a site that exhibits the issue?

Also, are you using unicode characters? ie, characters that aren't found in the ASCII charset? I wonder if this has something to do with the unicode migration in trunk.

comment:2 Changed 8 years ago by perus@…

I'm using 'default encoding', but I've checked that I have the same result regardless of selected encoding. Hereafter an example of url given by clicking on the 'blog tag' in the right down corner of a blog post:

http://127.0.0.1/Projets/Docs/tags/%27blog%27

comment:3 Changed 8 years ago by pacopablo

I can't duplicate this. All of my links work fine. Does it only happen when you use the BlogPost page? Or do you have the same behavior when you add tags via a wiki page?

It would appear that %27 is the URL encoded form of '

Are you putting quotes around your tags?

I tried adding tags with and without quotes in both the wiki and the blog and I can't duplicate this.

comment:4 Changed 8 years ago by pacopablo

  • Resolution set to invalid
  • Status changed from assigned to closed

I just talked to alect and it appears that the reason the tags are getting quoted is due to new code in the tags plugin.

I am still unsure why the quotes are getting URL encoded as ' should be a safe character.

However, please sumbit this ticket to the tags project, as it's not actually a blog bug.

http://muness.textdriven.com/trac/newticket

comment:5 Changed 8 years ago by athomas

This is fixed in tags:changeset:238.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from pacopablo. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.