Modify

Opened 6 years ago

Closed 23 months ago

#3079 closed defect (duplicate)

Search error: "TypeError: can't compare datetime.datetime to int"

Reported by: beinstein@… Owned by: cboos
Priority: high Component: DoxygenPlugin
Severity: major Keywords: search, genshi
Cc: Trac Release: 0.11

Description

I received this error after upgrading to Genshi 0.5dev-r852 and trying to perform a search. While I'm not positive it's due to the doxygen plugin, logging in as a user that doesn't have permissions to the Doxygen page does not cause the error when searching.

Attachments (2)

doxygentrac-typeerror-comparison-datetime-float-fix.patch (1.3 KB) - added by giel 6 years ago.
fix for this bug
doxygentrac-typeerror-comparison-datetime-float-fix.2.patch (1.4 KB) - added by giel 6 years ago.
Use the correct timezone as well (previous patch didn't do that); as a result the patch in #3000 doesn't work either, this one does (tested & confirmed): http://developer.wz2100.net/search?q=language

Download all attachments as: .zip

Change History (7)

comment:1 Changed 6 years ago by anonymous

I'm getting the same error. Toggling Doxygen on/off in the search page makes the difference between error and no error for me, so I believe the poster is correct about it being the doxygen plugin's fault.

comment:2 Changed 6 years ago by giel

I can confirm Doxygen to be the cause of this and have a patch that fixes this attached.

Changed 6 years ago by giel

fix for this bug

comment:3 Changed 6 years ago by giel

Hmm, I just saw that this bug (and my fix) are similar to #3000.

Changed 6 years ago by giel

Use the correct timezone as well (previous patch didn't do that); as a result the patch in #3000 doesn't work either, this one does (tested & confirmed): http://developer.wz2100.net/search?q=language

comment:4 Changed 5 years ago by rjollos

Adding myself to receive notifications.

comment:5 Changed 23 months ago by rjollos

  • Resolution set to duplicate
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.