Modify

Opened 6 years ago

Closed 6 years ago

#3304 closed defect (duplicate)

Doesn't work for me

Reported by: jpschewe@… Owned by: pkropf
Priority: normal Component: GraphvizPlugin
Severity: critical Keywords:
Cc: andreas.wurzer@…, adieu@… Trac Release: 0.11

Description

When I put the same graph into my wiki page:

Error: Failed to load processor graphviz
No macro or processor named 'graphviz' found

I get:

Graphviz macro processor has detected an error. Please fix the problem before continuing.

The command

['/usr/bin/dot', , '-Tsvg', u'-o/tmp/a6c54c328e02fc2da0d3145c16a67a3b5a51269e.dot.png.svg']

failed with the the following output:

Error: dot: can't open

Attachments (1)

graphviz.diff (1.5 KB) - added by anonymous 6 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 6 years ago by anonymous

Getting what looks to be the same error here...

The command

[u'C:
Program Files
Graphviz
bin
dot.exe', , u'-Tpng', u'-oD:
Python25
Scripts
trac
myproject
htdocs
graphviz
f83378112f5507cdc8d480101e65fceb1f185d94.dot.png']

failed with the the following output:

Error: dot: can't open

comment:2 Changed 6 years ago by anonymous

  • Cc andreas.wurzer@… added; anonymous removed

comment:3 Changed 6 years ago by Adieu

  • Cc adieu@… added

I had the same error here.

After looking into the source code, I found that the error was caused by sometimes self.processor_options is empty when generating the image and the map file.

I attached a little patch here. It solved my problem. Hope it is useful for people have the same problem.

Changed 6 years ago by anonymous

comment:4 Changed 6 years ago by anonymous

Hmm, I added the same changes to mine (had to do manually as I couldn't figure out how to download the raw diff, rather than the pretty version) and I get "IOError: [Errorno 32] Broken pipe.

comment:5 Changed 6 years ago by anonymous

Fixed it. There was another similar error around line 211 also around line 221 where rsvg is called, one needs to add '-o' as another command arg before img_path

                # 2. SVG to PNG rasterization
                cmd = [self.rsvg_path, '--dpi-x=%d' % self.dpi, '--dpi-y=%d' % self.dpi, '%s.svg' % img_path, '-o', img_path]

comment:6 Changed 6 years ago by Adieu

Great! I didn't use svg so I didn't run into that part of code.

comment:7 Changed 6 years ago by anonymous

This is definitely a bug, but the workaround for it is to add some processor related option to trac.ini like this:

[graphviz]
default_graph_fontsize = 8

comment:8 Changed 6 years ago by cboos

  • Resolution set to duplicate
  • Status changed from new to closed

Another duplicate of #3605.

Add Comment

Modify Ticket

Action
as closed The owner will remain pkropf.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.