Modify

Opened 6 years ago

Closed 5 years ago

Last modified 4 years ago

#3348 closed defect (duplicate)

ListTagged(...) fails with UTF-8 pagenames (not ascii) with /tags/0.6

Reported by: joonas.koivunen@… Owned by: athomas
Priority: normal Component: TagsPlugin
Severity: normal Keywords: ASCII UTF-8
Cc: Trac Release: 0.11

Description

It seems that tagsplugin doesn't work at all when you have tagged a wikipage with an UTF-8 name (for example "Ylläpito").

Log output:

2008-07-08 19:16:32,025 Trac[__init__] ERROR: Macro ListTagged(ylläpito) failed
Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/Trac-0.11-py2.4.egg/trac/wiki/formatter.py", line 468, in _macro_formatter
    return macro.process(args, in_paragraph=True)
  File "/usr/lib/python2.4/site-packages/Trac-0.11-py2.4.egg/trac/wiki/formatter.py", line 179, in process
    text = self.processor(text)
  File "/usr/lib/python2.4/site-packages/Trac-0.11-py2.4.egg/trac/wiki/formatter.py", line 166, in _macro_processor
    text)
  File "build/bdist.linux-i686/egg/tractags/macros.py", line 80, in expand_macro
  File "build/bdist.linux-i686/egg/tractags/macros.py", line 80, in <lambda>
UnicodeEncodeError: 'ascii' codec can't encode character u'\xe4' in position 16: ordinal not in range(128)

Tested with trac 0.11 in a system with a UTF-8 locale (fi_FI.UTF-8), debian 4.0.

Attachments (0)

Change History (7)

comment:1 Changed 6 years ago by joonas.koivunen@…

  • Keywords ascii utf-8 added

Additional information:

  • db backend is sqlite (per default installation)
  • this error occurs also on /tags?q='page named in utf-8' page, where Trac kindly asks to report a bug
  • error is not visible on the tag cloud itself

comment:2 Changed 6 years ago by joonas.koivunen@…

  • Summary changed from ListTagged(...) fails with UTF-8 pagenames (not ascii) to ListTagged(...) fails with UTF-8 pagenames (not ascii) with /tags/0.6

Upgrading from /tags/0.6 -> trunk fixed the problem.

Renaming this "... with /tags/0.6".

comment:3 follow-up: Changed 6 years ago by spira@…

This is only to testify that upgrading from /tags/0.6 -> trunk fixed the problem.

I am running Trac 0.11 on Windows XP and Python 2.4.

comment:4 in reply to: ↑ 3 Changed 6 years ago by henrik

Replying to spira@portussro.cz:

This is only to testify that upgrading from /tags/0.6 -> trunk fixed the problem.

I am running Trac 0.11 on Windows XP and Python 2.4.

Works for me to on Trac 0.11, Ubuntu with Python 2.4. Thanks a bundle.

comment:5 Changed 5 years ago by osimons

  • Resolution set to duplicate
  • Status changed from new to closed

Same issue that is reported in #3609, but also confirmed to be fixed in trunk. Please upgrade to trunk.

Perhaps a new 0.6.1 version should be tagged and published to pypi soon - proper unicode handling is quite important... athomas?

comment:6 Changed 5 years ago by osimons

Actually, #2493 seems to be the original ticket and fix.

comment:7 Changed 4 years ago by anonymous

  • Keywords ASCII UTF-8 added; ascii utf-8 removed

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from athomas. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.