Modify

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#3350 closed defect (worksforme)

GrowlPlugin easy_install fails on CentOS 5

Reported by: ben.lancaster@… Owned by: eblot
Priority: normal Component: GrowlPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

Failed to install GrowlPlugin.

Setup:

  • Python 2.4.3
  • easy_install 2.4
  • CentOS 5 (2.6.18-92.1.6.el5 x86_64)
  • Trac 0.11
  • GrowlPlugin r3992 (last change r3950)

Traceback:

$ sudo python setup.py bdist_egg
running bdist_egg
Traceback (most recent call last):
  File "setup.py", line 38, in ?
    entry_points = {
  File "/usr/lib64/python2.4/distutils/core.py", line 149, in setup
    dist.run_commands()
  File "/usr/lib64/python2.4/distutils/dist.py", line 946, in run_commands
    self.run_command(cmd)
  File "/usr/lib64/python2.4/distutils/dist.py", line 965, in run_command
    cmd_obj.ensure_finalized()
  File "/usr/lib64/python2.4/distutils/cmd.py", line 117, in ensure_finalized
    self.finalize_options()
  File "/usr/lib/python2.4/site-packages/setuptools/command/bdist_egg.py", line 94, in finalize_options
    ei_cmd = self.ei_cmd = self.get_finalized_command("egg_info")
  File "/usr/lib64/python2.4/distutils/cmd.py", line 319, in get_finalized_command
    cmd_obj.ensure_finalized()
  File "/usr/lib64/python2.4/distutils/cmd.py", line 117, in ensure_finalized
    self.finalize_options()
  File "/usr/lib/python2.4/site-packages/setuptools/command/egg_info.py", line 85, in finalize_options
    self.vtags = self.tags()
  File "/usr/lib/python2.4/site-packages/setuptools/command/egg_info.py", line 179, in tags
    ):  version += '-r%s' % self.get_svn_revision()
  File "/usr/lib/python2.4/site-packages/setuptools/command/egg_info.py", line 196, in get_svn_revision
    dirurl = urlre.search(data).group(1)    # get repository URL
AttributeError: 'NoneType' object has no attribute 'group'

Attachments (0)

Change History (6)

comment:1 Changed 6 years ago by eblot

  • Severity changed from blocker to normal

Sorry, I can't reproduce this error neither on Mac OS X or on Debian.

Have you try to build other egg files from TracHacks on the same machine?

comment:2 follow-up: Changed 6 years ago by anonymous

Yeah – several. I have IniAdmin, TracAccountManager, TracMasterTickets, TracPermRedirect, TracXMLRpc all installed via the same method

Thanks for looking in to it

comment:3 in reply to: ↑ 2 Changed 6 years ago by eblot

Replying to anonymous:

Thanks for looking in to it

Would you know a freely downloadable VmWare image file that matches your environment ?
I may give a try w/ CentOS, but I really don't have the time to install a new environment from scratch...

comment:4 follow-up: Changed 6 years ago by ben.lancaster@…

You could give the LiveCD a try:

http://ftp.linux.ncsu.edu/pub/CentOS/5.1/isos/i386/CentOS-5.1-i386-LiveCD.iso

My environment is a fairly vanilla install (from "official" Binaries), so the LiveCD should do you just fine.

Thanks again

comment:5 in reply to: ↑ 4 Changed 6 years ago by eblot

  • Resolution set to worksforme
  • Status changed from new to closed

Replying to ben.lancaster@holler.co.uk:

You could give the LiveCD a try: http://ftp.linux.ncsu.edu/pub/CentOS/5.1/isos/i386/CentOS-5.1-i386-LiveCD.iso My environment is a fairly vanilla install (from "official" Binaries), so the LiveCD should do you just fine.

I just gave a try with this LiveCD (I add to install Subversion with the standard tool though): No issue to build the egg file, I just ran

python setup.py bdist_egg

So I guess there's something wrong on your installation, but I can't tell which one.

I can send you the egg file if that helps.

comment:6 Changed 6 years ago by ben.lancaster@…

If you could send over the egg file, then that'd be great.

thanks again

Add Comment

Modify Ticket

Action
as closed The owner will remain eblot.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.