Modify

Opened 6 years ago

Closed 6 years ago

#3573 closed defect (worksforme)

PageToDoc failure: 'ascii' codec can't decode byte

Reported by: anonymous Owned by: lei
Priority: normal Component: PageToDocIntegration
Severity: major Keywords:
Cc: Trac Release: 0.11

Description

I tried PageToDocIntegration but it fails even on simple page (i.e. 1 character) with the following stack:

Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/trac/web/api.py", line 339, in send_error
    'text/html')
  File "/usr/lib/python2.5/site-packages/trac/web/chrome.py", line 726, in render_template
    stream.render(method, doctype=doctype, out=buffer)
  File "/usr/lib/python2.5/site-packages/genshi/core.py", line 179, in render
    return encode(generator, method=method, encoding=encoding, out=out)
  File "/usr/lib/python2.5/site-packages/genshi/output.py", line 61, in encode
    for chunk in iterator:
  File "/usr/lib/python2.5/site-packages/genshi/output.py", line 311, in __call__
    for kind, data, pos in stream:
  File "/usr/lib/python2.5/site-packages/genshi/output.py", line 753, in __call__
    for kind, data, pos in stream:
  File "/usr/lib/python2.5/site-packages/genshi/output.py", line 592, in __call__
    for kind, data, pos in stream:
  File "/usr/lib/python2.5/site-packages/genshi/output.py", line 707, in __call__
    text = mjoin(textbuf, escape_quotes=False)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xe9 in position 977: ordinal not in range(128)

Here's the trac installation:

System Information
Trac: 	0.11
Python: 	2.5.2 (r252:60911, Aug 4 2008, 12:01:34) [GCC 4.1.2 (Gentoo 4.1.2 p1.0.2)]
setuptools: 	0.6c8
SQLite: 	3.5.9
pysqlite: 	2.3.2
Genshi: 	0.5.1
Pygments: 	0.10
Subversion: 	1.4.6 (r28521)
jQuery:	1.2.3

I could provide more information but i do not know what else could be interesting. For an empty page nothing happens (i.e. Firefox says page is loaded but nothing is proposed for download, but might be ok though).

Attachments (0)

Change History (1)

comment:1 Changed 6 years ago by markm

  • Resolution set to worksforme
  • Status changed from new to closed

Hi,

I could not reproduce this error.

I tried with a page with no content and you are right - it just opens a blank page. I haven't opened another bug to track that.

I tried with single character pages, even ones with different character sets and things like slashes - but could not reproduce the error.

Note - I note that none of the lines from the stack trace actually refer to the PageToDocIntegration plugin - so I would guess that this is caused by something else.

Add Comment

Modify Ticket

Action
as closed The owner will remain lei.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.