Modify

Opened 8 years ago

Closed 4 years ago

#374 closed defect (duplicate)

Unicode Problem?

Reported by: anonymous Owned by: rjollos
Priority: normal Component: RepoSearchPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.9

Description

Does the current version support unicode well?

Traceback (most recent call last):
  File "C:\Python23\Lib\site-packages\trac\web\main.py", line 299, in dispatch_request
    dispatcher.dispatch(req)
  File "C:\Python23\Lib\site-packages\trac\web\main.py", line 189, in dispatch
    resp = chosen_handler.process_request(req)
  File "C:\Python23\Lib\site-packages\trac\Search.py", line 181, in process_request
    results += list(source.get_search_results(req, terms, filters))
  File "build\bdist.win32\egg\tracreposearch\search.py", line 76, in get_search_results
  File "build\bdist.win32\egg\tracreposearch\indexer.py", line 104, in __init__
  File "build\bdist.win32\egg\tracreposearch\indexer.py", line 72, in wrap
  File "build\bdist.win32\egg\tracreposearch\indexer.py", line 209, in reindex
  File "C:\Python23\Lib\UserDict.py", line 152, in get
    return self[key]
  File "C:\Python23\Lib\bsddb\__init__.py", line 116, in __getitem__
    return self.db[key]
TypeError: String or Integer object expected for key, unicode found

Attachments (0)

Change History (5)

comment:1 Changed 8 years ago by anonymous

  • Resolution set to fixed
  • Status changed from new to closed

Sorry i just realize i was using a old release..

I just build from the latest trunk..

Every Thing seems works fine.

comment:2 Changed 7 years ago by r.sokoll@…

  • Resolution fixed deleted
  • Status changed from closed to reopened

I have the same problem on Linux.
trac 0.10.3, svn 1.4.3, apache 2.0.59, latest reposearch from trunk (revision 2033):

Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 387, in dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 237, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/lib/python2.4/site-packages/trac/Search.py", line 181, in process_request
    results += list(source.get_search_results(req, terms, filters))
  File "build/bdist.linux-i686/egg/tracreposearch/search.py", line 77, in get_search_results
  File "build/bdist.linux-i686/egg/tracreposearch/indexer.py", line 72, in wrap
  File "build/bdist.linux-i686/egg/tracreposearch/indexer.py", line 209, in reindex
  File "/usr/lib/python2.4/UserDict.py", line 158, in get
    return self[key]
  File "/usr/lib/python2.4/bsddb/__init__.py", line 213, in __getitem__
    return self.db[key]
TypeError: String or Integer object expected for key, unicode found

comment:3 Changed 4 years ago by rjollos

Reassigning ticket after changing maintainer of plugin.

comment:4 Changed 4 years ago by rjollos

  • Owner changed from athomas to rjollos
  • Status changed from reopened to new

comment:5 Changed 4 years ago by rjollos

  • Resolution set to duplicate
  • Status changed from new to closed

comment:2 appears to be a duplicate of #2324. Please follow that ticket for pending application of a patch, and if you still have a problem we can try to solve the issue after the patches have been applied.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from rjollos. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.