Modify

Opened 6 years ago

Closed 6 years ago

#3780 closed enhancement (fixed)

RFE: Add First/Last page links in Matrix view

Reported by: izzy Owned by: Blackhex
Priority: normal Component: ScreenshotsPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.10

Description

When you are just on it, something small here: Right now, Matrix View just offers previous/next page links. With many screenshots in the collection, it's not that easy to get to the last page to find out the number of the screenshot just added. A link like "first"/"last" page would be very helpful. Optionally you also could add something like "goto page x" ;)

Thank you in advance!

Attachments (0)

Change History (4)

comment:1 follow-up: Changed 6 years ago by Blackhex

  • Status changed from new to assigned

Implementation for 0.11 branch in r4355.

comment:2 in reply to: ↑ 1 Changed 6 years ago by anonymous

Replying to Blackhex:

Implementation for 0.11 branch in r4355.

I just tested this version and it gives me the error:

Traceback (most recent call last):
  File "/usr/local/lib/python2.5/site-packages/Trac-0.11.1-py2.5.egg/trac/web/main.py", line 423, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/lib/python2.5/site-packages/Trac-0.11.1-py2.5.egg/trac/web/main.py", line 197, in dispatch
    resp = chosen_handler.process_request(req)
  File "build/bdist.freebsd-7.0-RELEASE-p2-i386/egg/tracscreenshots/core.py", line 138, in process_request
    template, content_type = self._do_actions(context, actions)
  File "build/bdist.freebsd-7.0-RELEASE-p2-i386/egg/tracscreenshots/core.py", line 594, in _do_actions
    render_screenshots(context.req, self.data)
  File "build/bdist.freebsd-7.0-RELEASE-p2-i386/egg/tracscreenshots/matrix_view.py", line 70, in render_screenshots
    data['matrix'] = self._build_matrix(index, data['screenshots'])
  File "build/bdist.freebsd-7.0-RELEASE-p2-i386/egg/tracscreenshots/matrix_view.py", line 96, in _build_matrix
    row.append(screenshots[index + I])
IndexError: list index out of range

I suspect there is a case that isn't being handled when there are no screenshots to show.

comment:3 Changed 6 years ago by Blackhex

Empty screenshots works fine for me. This would be probably caused by negative index. I've added additional check in r4359.

comment:4 Changed 6 years ago by Blackhex

  • Resolution set to fixed
  • Status changed from assigned to closed

This will stay only in 0.11 branch.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from Blackhex. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.