Modify

Opened 6 years ago

Closed 10 months ago

#3842 closed defect (cantfix)

Error calculating changeset size? TypeError: unsupported operand type(s) for +: 'NoneType' and 'NoneType'

Reported by: mculbert AT gemstoneDOTcom Owned by: hvr
Priority: high Component: GitPlugin
Severity: critical Keywords:
Cc: Trac Release: 0.12

Description

We are getting the following exception for some of our changesets. I don't have a lot of info on the changeset itself, but I do know that "old_node.get_content_length()" is returning None when it should be an int.

We do have the Python 2.4 backport installed, but it's pretty much vanilla aside from that.

File "/usr/lib/python2.4/site-packages/Trac-0.11.1-py2.4.egg/trac/web/main.py", line 423, in _dispatch_request
  dispatcher.dispatch(req)
File "/usr/lib/python2.4/site-packages/Trac-0.11.1-py2.4.egg/trac/web/main.py", line 197, in dispatch
  resp = chosen_handler.process_request(req)
File "/usr/lib/python2.4/site-packages/Trac-0.11.1-py2.4.egg/trac/versioncontrol/web_ui/changeset.py", line 323, in process_request
  self._render_html(req, repos, chgset, restricted, xhr, data)
File "/usr/lib/python2.4/site-packages/Trac-0.11.1-py2.4.egg/trac/versioncontrol/web_ui/changeset.py", line 545, in _render_html
  diff_bytes += _estimate_changes(old_node, new_node)
File "/usr/lib/python2.4/site-packages/Trac-0.11.1-py2.4.egg/trac/versioncontrol/web_ui/changeset.py", line 501, in _estimate_changes
  return old_size + new_size

User Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.1) Gecko/2008071420 Firefox/2.0.0.3 (X11; U; Linux x86_64; en-US; rv:1.8.1.1)
Trac: 	0.11.1
Python: 	2.4.4 (#1, Apr 5 2007, 18:41:00) [GCC 4.1.2 20061115 (prerelease) (Debian 4.1.1-21)]
setuptools: 	0.6c3
pyPgSQL: 	2.5.1
Genshi: 	0.5.1
mod_python: 	3.2.10
GIT: 	1.5.6.2
jQuery:	1.2.6

Attachments (1)

gitplugin-traceback.txt (7.5 KB) - added by mike 6 years ago.
Full trac traceback

Download all attachments as: .zip

Change History (7)

Changed 6 years ago by mike

Full trac traceback

comment:1 Changed 6 years ago by anonymous

sounds like #3141

comment:2 Changed 5 years ago by thatch

Does changeset 82a7ea9a2073fadf8c310edd6ed8b3961d50aa36 contain anything interesting (like only directory changes or something)? I'm not sure there's enough here to reproduce the issue.

comment:3 Changed 4 years ago by hvr

  • Resolution set to invalid
  • Status changed from new to closed

since there isn't enough information to reproduce this problem, I'll have to close this ticket; feel free to reopen it when more information can be provided

comment:4 Changed 3 years ago by anonymous

  • Resolution invalid deleted
  • Status changed from closed to reopened

Error apears when change contains only submodule version update. Same error can be reproduced when change contains information about merge branch into master.

comment:5 Changed 3 years ago by daniel.lindau@…

  • Trac Release changed from 0.11 to 0.12

Hi,

We have the same problem with our implementation. Changesets that only contain changes to submodule versions give the same error as above.

Can we help in some way to get a resolution to this?

Regards
Daniel Lindau

comment:6 Changed 10 months ago by jun66j5

  • Resolution set to cantfix
  • Status changed from reopened to closed

That is Trac issue, t:#10162.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from hvr. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.