Modify

Opened 6 years ago

Closed 13 months ago

#3888 closed enhancement (cantfix)

WikiLinking branch heads?

Reported by: anonymous Owned by: hvr
Priority: normal Component: GitPlugin
Severity: normal Keywords: branch
Cc: xerdcire@…, slavazanko@… Trac Release: 0.11

Description

Is it possible to create a wikilink to a branch head? Using the SHA1 hash doesn't work of course because it doesn't track the HEAD

Attachments (0)

Change History (5)

comment:1 Changed 6 years ago by anonymous

  • Cc xerdcire@… added

comment:2 Changed 4 years ago by anonymous

  • Cc slavazanko@… added

comment:3 Changed 4 years ago by anonymous

I can confirm, that the immediate notation [log:@master] seems to be broken:

Trac detected an internal error:

ValueError: invalid literal for int() with base 10: '<sha1>'

[log:?rev=master] seems to work, though.

comment:4 Changed 4 years ago by hvr

seems related to #6216

comment:5 Changed 13 months ago by jun66j5

  • Resolution set to cantfix
  • Status changed from new to closed

That is a TracWiki issue. Also, log:@master works in Trac 0.12+.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from hvr. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.