Modify

Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#4370 closed defect (fixed)

Linking does not work for all possible link types

Reported by: soenke.brecht@… Owned by: mchua
Priority: normal Component: TracBacksPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

Automatic linking only works with 'Ticket #ID'. It does neither work with 'AnyLinkText nor with 'ticket:ID'

Attachments (0)

Change History (4)

comment:1 follow-up: Changed 6 years ago by mchua

  • Resolution set to fixed
  • Status changed from new to closed

http://trac-hacks.org/changeset/5150 enabled acceptance of the ticket:ID format. Tracbacks shouldn't be created when AnyLinkText is put down, since that doesn't refer to an unique ticket. Closing this as resolved; please reopen if there's another way to refer to an unique ticket that I've missed.

comment:2 in reply to: ↑ 1 ; follow-up: Changed 6 years ago by anonymous

  • Priority changed from high to normal
  • Resolution fixed deleted
  • Severity changed from critical to normal
  • Status changed from closed to reopened

Replying to mchua:

http://trac-hacks.org/changeset/5150 enabled acceptance of the ticket:ID format.

Thank you very much for that one. Will check that later.

Tracbacks shouldn't be created when AnyLinkText is put down, since that doesn't refer to an unique ticket.

You are right if you interpret AnyLinkText as CamelCase. Sorry for the unprofessional explanation given by me in the first place. I really should have used source code like I do now:

[ticket:ID AnyLinkText]

Can you please double check if this is recognised as well by your new implementation?

comment:3 in reply to: ↑ 2 ; follow-up: Changed 5 years ago by anonymous

  • Resolution set to fixed
  • Status changed from reopened to closed

Replying to anonymous:

Can you please double check if this is recognised as well by your new implementation?

I have [5618] installed, and I have confirmed that syntax is recognized.

comment:4 in reply to: ↑ 3 Changed 5 years ago by rjollos

Replying to anonymous:

I have [5618] installed, and I have confirmed that syntax is recognized.

Forgot to add my username.

Add Comment

Modify Ticket

Action
as closed The owner will remain mchua.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.