Modify

Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#456 closed defect (worksforme)

Link to download is not functioning

Reported by: Cowboy Owned by: Blackhex
Priority: normal Component: DiscussionPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.9

Description

Is there a problem with this plugin? I can not download because there is no link on the Wiki.

Thanks

Attachments (0)

Change History (6)

comment:1 Changed 8 years ago by cboos

  • Resolution set to worksforme
  • Status changed from new to closed

The InterMapTxt has been overwritten lately...
I restored the download: prefix, but I guess a
server restart would be needed
(generic problem with IWikiChangeListeners...)

After that, the download:discussionplugin link should give you the
proper download link, which is:
http://trac-hacks.org/changeset/latest/discussionplugin?old_path=/&format=zip

comment:2 follow-up: Changed 8 years ago by athomas

For AutoWikifyPlugin I found I had to add the following (hackish) code to clear the regex cache:

WikiSystem(self.env)._compiled_rules = None

Something similar (or an additional method for doing this) would probably fix the problem.

InterMapTxt seems to have been overwritten by a wiki upgrade. This is probably not ideal.

comment:3 in reply to: ↑ 2 ; follow-up: Changed 8 years ago by cboos

Replying to athomas:

Something similar (or an additional method for doing this) would probably fix the problem.


No, this is due to the fact of having multiple server processes for Trac,
when using some web front-ends (i.e. mod_python, Apache prefork):
the InterMapTxt save operation is done in one process, and by the way of
the IWikiChangeListener that change is correctly propagated to the InterWikiMap
component... but only inside that process, of course.

Subsequent requests reaching other processes still deal with InterWikiMap
components that were not notified of the change.

Actually this is similar to the problem of updating the cached list of
all Wiki pages. Currently the solution for this is quite heavy-weight
(periodically refreshing the cache) and I think we should find a way
to improve that in the future.


InterMapTxt seems to have been overwritten by a wiki upgrade. This is probably not ideal.

Eh, that's the risk for early adopters... But I'm afraid some kind
of manual merge is always needed in such cases.

comment:4 in reply to: ↑ 3 ; follow-up: Changed 8 years ago by athomas

Replying to cboos:

InterMapTxt seems to have been overwritten by a wiki upgrade. This is probably not ideal.

Eh, that's the risk for early adopters... But I'm afraid some kind
of manual merge is always needed in such cases.

It seems like pretty bad form to overwrite a page which by design is meant to be modified by end users.

I suggest we add InterMapTxt to the page load ignore list in trac/scripts/admin.py:

            self._do_wiki_load(default_dir('wiki'),
                               ignore=['WikiStart', 'checkwiki.py',
                                       'InterMapTxt'])

comment:5 in reply to: ↑ 4 ; follow-up: Changed 8 years ago by cboos

Replying to athomas:

I suggest we add InterMapTxt to the page load ignore list in trac/scripts/admin.py:
...

Sure, I forgot about this feature.

comment:6 in reply to: ↑ 5 Changed 8 years ago by cboos

Replying to cboos:

Replying to athomas:

I suggest we add InterMapTxt to the page load ignore list in trac/scripts/admin.py:
...

Sure, I forgot about this feature.

Oops, not exactly what's needed, but I'll do something similar:
only insert that page if it doesn't already exist.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.