Modify

Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#4617 closed defect (fixed)

erroneous setup.py: can't import "no module name py"

Reported by: jholg Owned by: takanorig
Priority: normal Component: WorkflowEditorPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

Hi,
setup.py is wrong in that no .py extensions should be in the entry_points definitions,
which results in an error when the plugin is supposed to get loaded.

The patch attached fixes this for me - unfortunately, I can only see the text interface, not the "grid editor".
I used the latest zip source (as opposed to the released versions).

Holger

Attachments (1)

workfloweditor_setup_patch.diff (506 bytes) - added by jholg 6 years ago.
setup.py patch, removing erroneous .py extension in entry_points

Download all attachments as: .zip

Change History (7)

Changed 6 years ago by jholg

setup.py patch, removing erroneous .py extension in entry_points

comment:1 Changed 6 years ago by takanorig

  • Status changed from new to assigned

The patch attached fixes this for me - unfortunately, I can only see the text interface, not the "grid editor". I used the latest zip source (as opposed to the released versions).

Now, this plugin (1.0beta) is only supported Japanese.
I will release the English supported version within the next week.
Please wait.

comment:2 Changed 6 years ago by takanorig

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [5266])
I'm release the English supported version.

comment:3 Changed 6 years ago by jholg

  • Resolution fixed deleted
  • Status changed from closed to reopened

Hi,
I haven't tried out yet but from browsing the code:

15         entry_points = {
17 	        'trac.plugins': [
18 	            'workfloweditor.workfloweditor_admin.py = workfloweditor.workfloweditor_admin.py',
19 	        ]
20 	    },

These lines still look faulty to me - the .py extension's not supposed to be there
(This is what my patch was addressing).

Regards,
Holger

comment:4 Changed 6 years ago by takanorig

I think that the ".py" extension in entry_points is invalid.
The other plugins are not written ".py".

When you installed, this plugin didn't work in English. You could only use the textarea without the tabs.

Please try out the latest version. It maybe work.

comment:5 Changed 5 years ago by takanorig

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [5329])
Fix the JavaScript error with IE6/IE7.
This revision is release 1.0.1

comment:6 Changed 5 years ago by jholg

Hi,

Sorry for the delay, I can confirm that the grid interface works for me now, in English (using release 1.0.1)
Cool Plugin!

Holger

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.