Modify

Opened 5 years ago

Closed 5 years ago

Last modified 3 years ago

#4622 closed defect (fixed)

Unable to install

Reported by: anonymous Owned by: kivsiak
Priority: normal Component: TypedTicketWorkflowPlugin
Severity: critical Keywords:
Cc: Trac Release: 0.11

Description

Running trac 0.11 on Windows, and have not been able to install is either through easy_install, or by creating an egg.

Here's the output from running python setup.py bdist_egg in the svn checkout of the plugin:

c:\Program Files\VisualSVN Server\trac\python\lib\distutils\dist.py:247: UserWar
ning: 'licence' distribution option is deprecated; use 'license'
  warnings.warn(msg)
running bdist_egg
unrecognized .svn/entries format; skipping .
running egg_info
creating TypedTicketWorkflow_plugin.egg-info
writing TypedTicketWorkflow_plugin.egg-info\PKG-INFO
writing top-level names to TypedTicketWorkflow_plugin.egg-info\top_level.txt
writing dependency_links to TypedTicketWorkflow_plugin.egg-info\dependency_links
.txt
writing entry points to TypedTicketWorkflow_plugin.egg-info\entry_points.txt
writing manifest file 'TypedTicketWorkflow_plugin.egg-info\SOURCES.txt'
Traceback (most recent call last):
  File "setup.py", line 11, in <module>
    entry_points = {'trac.plugins':['typedworkflow.controller = typedworkflow.co
ntroller']},
  File "C:\Program Files\VisualSVN Server\trac\python\lib\distutils\core.py", li
ne 151, in setup
    dist.run_commands()
  File "C:\Program Files\VisualSVN Server\trac\python\lib\distutils\dist.py", li
ne 974, in run_commands
    self.run_command(cmd)
  File "C:\Program Files\VisualSVN Server\trac\python\lib\distutils\dist.py", li
ne 994, in run_command
    cmd_obj.run()
  File "build/bdist.linux-i686/egg/setuptools/command/bdist_egg.py", line 167, i
n run
  File "C:\Program Files\VisualSVN Server\trac\python\lib\distutils\cmd.py", lin
e 333, in run_command
    self.distribution.run_command(command)
  File "C:\Program Files\VisualSVN Server\trac\python\lib\distutils\dist.py", li
ne 994, in run_command
    cmd_obj.run()
  File "build/bdist.linux-i686/egg/setuptools/command/egg_info.py", line 171, in
 run
  File "build/bdist.linux-i686/egg/setuptools/command/egg_info.py", line 252, in
 find_sources
  File "build/bdist.linux-i686/egg/setuptools/command/egg_info.py", line 306, in
 run
  File "build/bdist.linux-i686/egg/setuptools/command/egg_info.py", line 333, in
 add_defaults
  File "c:\Program Files\VisualSVN Server\trac\python\lib\site-packages\setuptoo
ls-0.6c8-py2.5.egg\setuptools\command\sdist.py", line 45, in walk_revctrl
  File "c:\Program Files\VisualSVN Server\trac\python\lib\site-packages\setuptoo
ls-0.6c8-py2.5.egg\setuptools\command\sdist.py", line 52, in _default_revctrl
  File "c:\Program Files\VisualSVN Server\trac\python\lib\site-packages\setuptoo
ls-0.6c8-py2.5.egg\setuptools\command\sdist.py", line 98, in entries_finder
NameError: global name 'log' is not defined

Is there anyway you can just provide the egg for the plug-in? Thanks!

Attachments (1)

TypedTicketWorkflow_plugin-0.1dev-py2.5.egg (3.0 KB) - added by kivsiak 5 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 5 years ago by kivsiak

  • Status changed from new to assigned

Could you please give me more information about your enviroment: Python and distutils version.

I'ts look like you have soume troubles with setuptools

comment:2 Changed 5 years ago by anonymous

Running Python 2.5.2 installed as part of the VisualSVN (http://www.visualsvn.com/server/trac/) on Windows 2003 Server.

comment:3 Changed 5 years ago by anonymous

BTW, This is in response to our attempt to address this issue:

http://stackoverflow.com/questions/543224/adding-multi-user-approval-process-in-trac-workflow

Which has lead us to install the plug-in. Thanks!

Changed 5 years ago by kivsiak

comment:4 Changed 5 years ago by kivsiak

  • Resolution set to wontfix
  • Status changed from assigned to closed

Sorry. I have downloaded and installed VisualSVN from http://www.visualsvn.com/server/trac/ under WinXP SP2 and cannot reproduce your error. Unfortunately i have no access to win2003 Server to test. However I've attached the produced egg to this ticket. Hope it helps.

comment:5 Changed 5 years ago by kivsiak

  • Resolution wontfix deleted
  • Status changed from closed to reopened

comment:6 Changed 5 years ago by chrisheller

  • Resolution set to fixed
  • Status changed from reopened to closed

Just FYI for anyone hitting this - that error is a known issue with that particular version of setuptools (setuptools-0.6c8). The solution is to upgrade setuptools to a later version.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from kivsiak. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.