Modify

Opened 6 years ago

Closed 5 years ago

#4715 closed defect (duplicate)

Duplicating records for hours worked on a user in ticket_change table in postgresql

Reported by: anebi Owned by: coling
Priority: normal Component: WorkLogPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

Hi,

We have installed these modules: trac-0.11.2.1 timingandestimationplugin_branches_trac0.11-r5257.zip worklogplugin-r5257.zip.

We noticed that there is a problem with duplicating records for work hours per user in table ticket_change in postgresql database. The problem is reproducing this way:

Go to a ticket and press: Start work.

Then without stopping the work, we just change resolution to something (for example Fixed) and apply changes. Then work is stopping and ticket is closing. After then in database i see 2 records for hours.

Like these:

13 1235734626 anebi hours 0.0 2.81 13 1235734625 anebi comment 4 anebi worked on this ticket for 2 hours, 48 minut... 13 1235734625 anebi hours 0 2.81 13 1235734626 anebi comment 3 - Made some tests with PHPFileNavigator.

You see the hours field and value. They are the same. Only different is timestamp. This happens because worklog/timingandestimationplugin is recorded this 1 second before the other record.

I don't know witch one (worklog or timingandestimationplugin) is responsible for this.

Attachments (0)

Change History (3)

comment:1 Changed 6 years ago by anebi

With the previous versions i know that the comment was create this way for worklog and the other comment:

anebi worked on this ticket for 2 hours, 48 minut...

  • Made some tests with PHPFileNavigator.

All this was one comment and the timestamp was ok. It was working ok at all.

comment:2 Changed 6 years ago by bobbysmith007

  • Component changed from TimingAndEstimationPlugin to WorkLogPlugin
  • Owner changed from bobbysmith007 to coling

Pretty sure this is a worklog thing (based on what is described). If I am wrong feel free to reassign back to me.

Russ

comment:3 Changed 5 years ago by coling

  • Resolution set to duplicate
  • Status changed from new to closed

This is a dup of #4712.

Add Comment

Modify Ticket

Action
as closed The owner will remain coling.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.