Modify

Opened 5 years ago

Closed 4 years ago

#4778 closed defect (worksforme)

memory error searching large repository using RepoSearchPlugin

Reported by: jeffrey.lyon@… Owned by: rjollos
Priority: normal Component: RepoSearchPlugin
Severity: major Keywords:
Cc: jeffrey.lyon@… Trac Release: 0.11

Description

How to Reproduce

While doing a GET operation on /search, Trac issued an internal error.

Ran a search after installing repoSearchPlugin on a repository containing 10GB in 2000 files). The computer has 110GB of free disk space and 3GB or RAM. The search ran for several minutes and then the memory error was reported. The error is repeatable with this repository, but searches run successfully on other smaller repositories.

Request parameters:

{'noquickjump': u'1', 'q': u'bla', 'repo': u'on'}

User Agent was: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.7) Gecko/2009021910 Firefox/3.0.7

System Information

Trac 0.11
Python 2.5.2 |EPD Py25 4.1.30101| (r252:60911, Dec 19 2008, 13:49:12) [MSC v.1310 32 bit (Intel)]
setuptools 0.6c9-s1
SQLite 3.3.4
pysqlite 2.3.2
Genshi 0.5
Pygments 0.10.0001
Subversion 1.5.4 (r33841)
jQuery: 1.2.3

Python Traceback

Traceback (most recent call last):
  File "C:\Python25\Lib\site-packages\trac\web\main.py", line 423, in _dispatch_request
    dispatcher.dispatch(req)
  File "C:\Python25\Lib\site-packages\trac\web\main.py", line 197, in dispatch
    resp = chosen_handler.process_request(req)
  File "C:\Python25\Lib\site-packages\trac\search\web_ui.py", line 106, in process_request
    results += list(source.get_search_results(req, terms, filters))
  File "build\bdist.win32\egg\tracreposearch\search.py", line 112, in get_search_results
    for node in walker(repo, query):
  File "build\bdist.win32\egg\tracreposearch\search.py", line 93, in full_walker
    content = to_unicode(content.read().lower(), node.get_content_type())
  File "C:\Python25\Lib\site-packages\trac\mimeview\api.py", line 789, in to_unicode
    return to_unicode(content, charset)
  File "C:\Python25\Lib\site-packages\trac\util\text.py", line 59, in to_unicode
    return unicode(text, charset, 'replace')
  File "C:\Python25\lib\encodings\iso8859_15.py", line 15, in decode
    return codecs.charmap_decode(input,errors,decoding_table)
MemoryError


Attachments (0)

Change History (3)

comment:1 Changed 4 years ago by rjollos

Reassigning ticket after changing maintainer of plugin.

comment:2 Changed 4 years ago by rjollos

  • Owner changed from athomas to rjollos

comment:3 Changed 4 years ago by rjollos

  • Resolution set to worksforme
  • Status changed from new to closed

Since this report is over a year old I'm closing, but please reopen if you wish to work on solving the issue.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from rjollos. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.