Modify

Opened 6 years ago

Closed 6 years ago

#4796 closed defect (duplicate)

Error by uploading small file

Reported by: roehricht@… Owned by: Blackhex
Priority: normal Component: DownloadsPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

An error occurs whenever we upload a simple md5sum-file (see attachement):

Oops...
Trac detected an internal error: 
AttributeError: 'cStringIO.StringO' object has no attribute 'len'

If you think this should work you can reproduce the problem, you should
consider reporting this to the Trac team.

Before you do that, though, please first try searching for similar issues,
as it is quite likely that this problem has been reported before. For
questions about installation and configuration of Trac, please try the
mailing list instead of filing a ticket. 

Otherwise, please  a new ticket at the Trac project site, where you can
describe the problem and explain how to reproduce it.
Python Traceback
Most recent call last: 
File "/usr/lib/python2.5/site-packages/trac/web/main.py", line 423, in
_dispatch_request 
File "/usr/lib/python2.5/site-packages/trac/web/main.py", line 197, in
dispatch 
File "/usr/lib/python2.5/site-packages/trac/admin/web_ui.py", line 113, in
process_request 
File "build/bdist.linux-x86_64/egg/tracdownloads/admin.py", line 43, in
render_admin_panel 
File "build/bdist.linux-x86_64/egg/tracdownloads/api.py", line 353, in
process_downloads 
File "build/bdist.linux-x86_64/egg/tracdownloads/api.py", line 534, in
_do_action 
File "build/bdist.linux-x86_64/egg/tracdownloads/api.py", line 813, in
_get_file_from_req 


System Information:

User Agent: Opera/9.64 (Windows NT 5.1; U; de) Presto/2.1.1Trac:
0.11.1
Python:	2.5.2 (r252:60911, Jan 4 2009, 22:17:10) [GCC 4.3.2]
setuptools:	0.6c9
SQLite:	3.5.9
pysqlite:	2.4.1
Genshi:	0.5.1
mod_python:	3.3.1
Pygments:	0.10
jQuery:	1.2.6

Server configuration: Debian Lenny with Trac version 0.11.1, DownloadsPlugin version 0.2

Attachments (1)

distack-1.1.0-dev.tar.gz.md5sum (59 bytes) - added by roehricht@… 6 years ago.
simple text file with md5sum and file name

Download all attachments as: .zip

Change History (2)

Changed 6 years ago by roehricht@…

simple text file with md5sum and file name

comment:1 Changed 6 years ago by Blackhex

  • Resolution set to duplicate
  • Status changed from new to closed

I believe it's duplicate of #2152.

Add Comment

Modify Ticket

Action
as closed The owner will remain Blackhex.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.