Modify

Opened 6 years ago

Closed 6 years ago

#4801 closed defect (duplicate)

UnicodeEncodeError: 'ascii' codec can't encode characters in position

Reported by: dreel@… Owned by: athomas
Priority: highest Component: TagsPlugin
Severity: blocker Keywords: UnicodeEncodeError
Cc: Trac Release: 0.11

Description

Tags not working after adding new tag in any language (Ru,Eng)

Python Traceback
Most recent call last: 
File "C:\usr\python\Lib\site-packages\trac\web\main.py", line 435, in _dispatch_request
  dispatcher.dispatch(req)
File "C:\usr\python\Lib\site-packages\trac\web\main.py", line 205, in dispatch
  resp = chosen_handler.process_request(req)
File "build\bdist.win32\egg\tractags\web_ui.py", line 99, in process_requestFile "build\bdist.win32\egg\tractags\macros.py", line 80, in expand_macroFile "build\bdist.win32\egg\tractags\macros.py", line 80, in <lambda>

System Information:

User Agent: Opera/9.63 (Windows NT 5.1; U; ru) Presto/2.1.1Trac: 0.11.3 Python: 2.5.2 (r252:60911, Feb 21 2008, 13:11:45) [MSC v.1310 32 bit (Intel)] setuptools: 0.6c7 SQLite: 3.5.2 pysqlite: 2.4.0 Genshi: 0.5.1 mod_python: 3.3.1 Pygments: 0.11.1 Subversion: 1.5.4 (r33841) jQuery: 1.2.6

I think a wiki page names include non-ascii characters can cause this error. Is it Trac of Tags bug?

Attachments (0)

Change History (1)

comment:1 Changed 6 years ago by osimons

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #2493 (and others). Please upgrade to tags trunk.

Add Comment

Modify Ticket

Action
as closed The owner will remain athomas.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.