Modify

Opened 5 years ago

Closed 5 years ago

#4854 closed defect (worksforme)

dependency check gives error against tidy even though it appears to be installed.

Reported by: Adrian Owned by: markm
Priority: normal Component: PageToDocIntegration
Severity: normal Keywords:
Cc: mtnbikingmark@… Trac Release: 0.11

Description

Mark,

Hi I'm glad this is being worked on again and I'm just looking at installing it.
First problem I've found is that it flags up an error finding tidy, even when I have defined a tidypath in the ini file.

I believe the problem is in the dependency_failure routine line 302 of pagetodoc.py

if os.system("%s %s"% (path, arguments)):

This returns 1 for me hence the error. If it's checking the dependency then should it be

if os.system("%s/%s %s"% (path,dependency, arguments)):

For info I'm running Tracs on WinXp so I'm not sure what would happen on Linux. Also what happens to the routine if tidypath is not defined?

Finally when creating this ticket it defaulted to "Assign to: Lei" I hope you don't mind that I changed it to yourself.

Regards

Adrian

Attachments (0)

Change History (4)

comment:1 Changed 5 years ago by markm

No problem assigning to me - thanks :)

Can you give the exact value for tidypath configuration value? It sounds like maybe you have not included tidy.exe in the path.

i.e.

[pagetodoc]
tidypath = c:\tools\tidy\tidy.exe

The reason for not making the change as you suggest it is that it would not work for the case where tidy is just on the path somewhere (the default if no tidypath configuration parameter is defined).

comment:2 Changed 5 years ago by anonymous

  • Cc mtnbikingmark@… added

comment:3 Changed 5 years ago by Adrian

Hi,

Doh! - yes this one is down to user error.

I've added tidy.exe and xsltproc.exe to the path definition as you suggest and it all works fine. Unfortunately I think when I read the instructions I treated tidypath as the just the directory name rather than the full path.

many thanks for your help

Adrian

comment:4 Changed 5 years ago by anonymous

  • Resolution set to worksforme
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.