Modify

Opened 5 years ago

Closed 5 years ago

#4858 closed defect (fixed)

com.sun.star.uno.Exception on Debian 5 (Lenny)

Reported by: Xarkam Owned by: sfhynx
Priority: normal Component: WikiExportPlugin
Severity: major Keywords:
Cc: Trac Release: 0.11

Description

Hi,
After installed the required python module (imagefile), i start openoffice with

/usr/bin/soffice "-accept=socket,host=localhost,port=8100;urp;StarOffice.ServiceManager" -nologo -headless -nofirststartwizard

And i receive this error with no message:

com.sun.star.uno.Exception: 

This is the trac.log:

2009-03-30 20:22:06,788 Trac[main] ERROR: Internal Server Error:
Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/Trac-0.11.4stable_r7988-py2.5.egg/trac/web/main.py", line 435, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.5/site-packages/Trac-0.11.4stable_r7988-py2.5.egg/trac/web/main.py", line 205, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/lib/python2.5/site-packages/Trac-0.11.4stable_r7988-py2.5.egg/trac/wiki/web_ui.py", line 165, in process_request
    format, versioned_page.name)
  File "/usr/lib/python2.5/site-packages/Trac-0.11.4stable_r7988-py2.5.egg/trac/mimeview/api.py", line 914, in send_converted
    content, selector)
  File "/usr/lib/python2.5/site-packages/Trac-0.11.4stable_r7988-py2.5.egg/trac/mimeview/api.py", line 640, in convert_content
    output = converter.convert_content(req, mimetype, content, ck)
  File "build/bdist.linux-i686/egg/exportplugin/export.py", line 66, in convert_content
    parser.write(self.env,'<body>' + cadena + '</body>',req.base_url)
  File "build/bdist.linux-i686/egg/exportplugin/formatter.py", line 176, in write
    self.procesarContent(element)
  File "build/bdist.linux-i686/egg/exportplugin/formatter.py", line 163, in procesarContent
    self.action(element, token, tipo, nivel)
  File "build/bdist.linux-i686/egg/exportplugin/formatter.py", line 138, in action
    self.procesarContent(token, element.name,nivel)
  File "build/bdist.linux-i686/egg/exportplugin/formatter.py", line 163, in procesarContent
    self.action(element, token, tipo, nivel)
  File "build/bdist.linux-i686/egg/exportplugin/formatter.py", line 138, in action
    self.procesarContent(token, element.name,nivel)
  File "build/bdist.linux-i686/egg/exportplugin/formatter.py", line 156, in procesarContent
    self.writeElement(element, tipo)
  File "build/bdist.linux-i686/egg/exportplugin/formatter.py", line 78, in writeElement
    self.exporter.generateBreakContent()
  File "build/bdist.linux-i686/egg/exportplugin/service.py", line 156, in generateBreakContent
    self.cursor.ParaStyleName = self.__STYLES[self.DEFAULT]
com.sun.star.uno.Exception:

OpenOffice run corretly, i use Alfresco GED on this server for export in pdf.

Attachments (0)

Change History (8)

comment:1 Changed 5 years ago by sfhynx

Hi,

have you define this section in trac.ini?

 [openOffice-exporter]
 user = john
 psswrd = 1234
 host = localhost
 port = 8100
 styles = Default, Heading 1, Heading 2, Heading 3
 enum-styles = List 1, List 2, List 3
 num-styles = Numbering 1, Numbering 2, Numbering 3

the three last parameters are important, because this plugin use for default the Spanish styles. You must define these three parameters for a english Open Office.

comment:2 Changed 5 years ago by sfhynx

  • Status changed from new to assigned

comment:3 Changed 5 years ago by Xarkam

Yes:

[openOffice-exporter]
host = localhost
port = 8100
styles = Default, Heading 1, Heading 2, Heading 3
enum-styles = List 1, List 2, List 3
num-styles = Numbering 1, Numbering 2, Numbering 3

Is defined in my trac.ini after the notification section.

comment:4 Changed 5 years ago by sfhynx

Ok. I'm installing a Debian 5 to test this problem.

comment:5 Changed 5 years ago by sfhynx

Hi. I'm install a Debian 5 virtual machine, with the requisites, and define the !openOffice-exporter section with a English OpenOffice, and don't have any problems. Can you send me the trac.ini for test? I'm using a utf-8 encoding.

comment:6 follow-up: Changed 5 years ago by sfhynx

sorry, the section is openOffice-exporter, not !openOffice-exporter

comment:7 in reply to: ↑ 6 Changed 5 years ago by Xarkam

Resolved.
After remove and re-install oOO the exporter running perfectly.
It's due to an upgrade from debian 4 to 5 but i do not know the cause

comment:8 Changed 5 years ago by anonymous

  • Resolution set to fixed
  • Status changed from assigned to closed

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from sfhynx. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.