Modify

Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#490 closed task (fixed)

Email notification is not sent

Reported by: micah@… Owned by: bas
Priority: high Component: EmailtoTracScript
Severity: major Keywords:
Cc: herbertv@… Trac Release: 0.10

Description

I've upgraded trac .10 to a more recent version from subversion and now when I send email in (via email2trac) response notifications are no longer sent to the person submitting the ticket via email. Neither the initial email from the submission, nor any updates that are made to the ticket description. However, when a ticket is closed, a notification is sent.

There is nothing in the DEBUG log that I can see during the initial submission. However, when I add a comment to the ticket after its been submitted, I see this:

2006-07-05 18:48:32,360 Trac[notification] INFO: Email address w/o domain: micah anderson

When I close the ticket, a proper notification is sent, and it appears in the log:

2006-07-05 18:48:32,368 Trac[notification] DEBUG: Sending SMTP notification to mail.nysite.coop on port 25 to [u'submitteremail@gmail.com', u'updateremai@mysite.net']

Attachments (0)

Change History (9)

comment:1 follow-up: Changed 8 years ago by bas

  • Cc micah@… added

I am not using 0.10. So is there something changed in notfication section for trac.ini? Look for new
notfication options.

I you fill in a bug with the web interface then there must also an email be sent to the reporter else this a bug in in 0.10 version of trac.

Hope this helps

comment:2 in reply to: ↑ 1 Changed 8 years ago by anonymous

Replying to bas:

I am not using 0.10. So is there something changed in notfication section for trac.ini? Look for new
notfication options.

I looked and found the following were not part of my trac.ini:

use_short_addr = true
always_notify_updater = true
smtp_always_bcc =
mime_encoding = base64
use_public_cc = true
smtp_default_domain = 

So I set them and restarted everything and ran a test, no notification was sent. :(

I you fill in a bug with the web interface then there must also an email be sent to the reporter else this a bug in in 0.10 version of trac.

Yes, this works... however submitting a new ticket via the web interface means that trac has my email address appropriately. I think the problem is that email2trac is not finding the correct email address in the email that is sent in.

Is there a way I can look at the database to see what is set as the email address for the person who submitted a ticket via email?

comment:3 Changed 8 years ago by anonymous

Yes you can you have to install, the sqlite command line tool, eg for debian:

  • apt-get install sqlite

Then you can access the database and use standard SQL statements, eg:

  • sqlite /data/trac/test/db/trac.db
  • SELECT * FROM ticket;

Hope this helps

comment:4 in reply to: ↑ description Changed 8 years ago by anonymous

Replying to micah@riseup.net:

I found that version 3468 of notification.py broke this behavior, and have filed a ticket with trac on that issue, here.

Its clearly a change in notification.py that caused this, however it is not clear to me if email2trac needs to be modified to work with this new behavior, or if there is a genuine problem with notification.py.

comment:5 Changed 8 years ago by bas

  • Status changed from new to assigned

Oke thanks for the report. I will read it and maybe i have to adjust the email2trac package

comment:6 Changed 8 years ago by anonymous

there has been an update to that ticket that requires the email2trac author to respond about how that plugin works.

comment:7 Changed 8 years ago by anonymous

The email notification API was reverted back to what it was before. The email2trac plugin script has not been tested against r3550 of .10 though. If anyone is running that, please test!

comment:8 Changed 8 years ago by anonymous

  • Resolution set to fixed
  • Status changed from assigned to closed

Close it

comment:9 Changed 7 years ago by anonymous

  • Cc herbertv@… added; micah@… removed
  • Priority changed from normal to high
  • Severity changed from normal to major
  • Type changed from defect to task

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.