Modify

Opened 6 years ago

Closed 6 years ago

#4954 closed defect (duplicate)

TypeError: __init__() takes at most 12 arguments (13 given)

Reported by: anonymous Owned by: k0s
Priority: highest Component: TracHoursPlugin
Severity: blocker Keywords: Internal error, blocker
Cc: Trac Release: 0.11

Description

After Install, enable the component and run trac-admin <env> upgrade, I restart the apache server.

When I doing a GET operation on /hours, Trac issued an internal error:

-- Oops… -- Trac detected an internal error:

TypeError: init() takes at most 12 arguments (13 given)

-- Python Traceback -- Most recent call last:

File "c:\archivos de programa\python25\lib\site-packages\Trac-0.11b2-py2.5.egg\trac\web\main.py", line 419, in _dispatch_request

dispatcher.dispatch(req)

File "c:\archivos de programa\python25\lib\site-packages\Trac-0.11b2-py2.5.egg\trac\web\main.py", line 196, in dispatch

resp = chosen_handler.process_request(req)

File "c:\archivos de programa\python25\lib\site-packages\trachoursplugin-0.3.1-py2.5.egg\trachours\hours.py", line 150, in process_request

return self.process_timeline(req)

File "c:\archivos de programa\python25\lib\site-packages\trachoursplugin-0.3.1-py2.5.egg\trachours\hours.py", line 487, in process_timeline

max)

-- System Information: --

User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; es-ES; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5 Trac: 0.11b2 Python: 2.5.2 (r252:60911, Feb 21 2008, 13:11:45) [MSC v.1310 32 bit (Intel)] setuptools: 0.6c9 SQLite: 3.5.2 pysqlite: 2.4.1 Genshi: 0.5.1 mod_python: 3.3.1 Subversion: 1.4.6 (r28521) jQuery: 1.2.3

Attachments (0)

Change History (1)

comment:1 Changed 6 years ago by otaku42

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #4955.

Add Comment

Modify Ticket

Action
as closed The owner will remain k0s.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.