Modify

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#499 closed defect (worksforme)

Db needs to upgraded

Reported by: jouvin@… Owned by: eblot
Priority: normal Component: TracFrenchTranslation
Severity: normal Keywords:
Cc: Trac Release: 0.10

Description

After solving previous errors, I am facing the error 'database needs to be upgraded'. this happens with a project freshly created with trac-admin for French Trac distribution. If I try to upgrade it again (normally it is harmless), I get the following error :

as3/root % pro-fr/bin/trac-admin /projects/trac-fr/Test upgrade
Command failed: 'pysqlite2.dbapi2.Connection' object has no attribute 'to_sql'

Error reported when trying to open the french project :

 /www/Web/servers/trac/pro-fr/lib/python2.4/site-packages/trac/web/main.py in _open_environment(env_path='/projects/trac-fr/Test', run_once=False) 
   55     try:
 
   56         if not env_path in env_cache:
 
   57             env_cache[env_path] = open_environment(env_path)
 
   58         env = env_cache[env_path]
 
   59     finally:
 
global env_cache = {}, env_path = '/projects/trac-fr/Test', global open_environment = <function open_environment> 
 /www/Web/servers/trac/0.10-french-1005/lib/python2.4/site-packages/trac/env.py in open_environment(env_path='/projects/trac-fr/Test') 
  476     env = Environment(env_path)
 
  477     if env.needs_upgrade():
 
  478         raise TracError, "L'environment Trac doit être mis à jour. Utilisez " \
 
  479                          "trac-admin %s upgrade" % env_path
 
  480     return env
 
global TracError = <class trac.core.TracError>, env_path = '/projects/trac-fr/Test' 

Attachments (0)

Change History (2)

comment:1 Changed 8 years ago by anonymous

  • Resolution set to worksforme
  • Status changed from new to closed

Sorry for this report, the problem was caused by TracDiscussionPlugin that seems to have a problem with the french Trac version.

Michel

comment:2 Changed 8 years ago by jouvin@…

For completeness, there is not problem with last version of DiscussionPlugin (0.4). The problem was caused by misconfiguration of plugin loading information.

Add Comment

Modify Ticket

Action
as closed The owner will remain eblot.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.