Modify

Opened 9 years ago

Closed 9 years ago

#509 closed task (fixed)

clarification and documentation needed

Reported by: nanderson@… Owned by: mgood
Priority: normal Component: AccountManagerPlugin
Severity: normal Keywords: documentation
Cc: Trac Release: 0.10

Description

This page should mention how to use the plugin. I had to go to a site that already had it enabled to know what URL to use to create a new account (e.g. http://example.com/Project/register).

Also there is this note: Also, remember to remove or comment out the directory entry matching "login" in your trac.conf file.

Being new to Trac I have run into a number problems trying to figure out that statement. First, I cannot find a "trac.conf" file, so I assume that what was meant is "/var/trac/Project/conf/trac.ini". And in that file the only reference I can find to "login" is in the "metanav" property. But removing "login" from that list only changes the placement of the "login" link in the nav bar.

Currently I have been able to register a number of new accounts and verifying the creation of new entries in the trac.htpasswd file. But I cannot actually log in... I'm guessing that the problem is with the default login mechanism is still in place...

Attachments (0)

Change History (5)

comment:1 Changed 9 years ago by irefuse

  • Priority changed from normal to high
  • Trac Release changed from 0.9 to 0.10

im having a bit of trouble along these lines as well... i think it's because im running trac as a standalone server via tracd... so how would i go about getting the login to work right if assuming that the site.com/login url is hardcoded into the daemon

comment:2 Changed 9 years ago by irefuse

  • Priority changed from high to normal
  • Resolution set to worksforme
  • Status changed from new to closed

ah just figured it out... if you are running the standalone daemon via tracd remove all of the --auth entries...i should have tried that first...didnt even click to me

comment:3 Changed 9 years ago by melinate

  • Resolution worksforme deleted
  • Status changed from closed to reopened

This ticket is about documentation more than specific problems. I eventually figured things out too, but it would have been easier if there were some instruction included.

comment:4 Changed 9 years ago by r.blum@…

There's also the issue that you need to mark 'acct_mgr.*' as enabled in your components, otherwise registration is not enabled.

comment:5 Changed 9 years ago by mgood

  • Keywords documentation added
  • Resolution set to fixed
  • Status changed from reopened to closed

I overhauled the documentation recently, so hopefully it will help explain things more thoroughly.

Add Comment

Modify Ticket

Action
as closed The owner will remain mgood.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.