Modify

Opened 5 years ago

Closed 3 years ago

#5189 closed defect (worksforme)

UserManagerPlugin broken

Reported by: abalter Owned by: cbalan
Priority: highest Component: UserManagerPlugin
Severity: blocker Keywords:
Cc: Trac Release: 0.11

Description

Suddenly, the UserManagerPlugin web interface (Admin>Users) is
throwing an error (see screenshot at http://myotherstuff.org/share/usermanagerplugin_problem.png).

I would like to uninstall and reinstall to fix, but can't uninstall!
Others are having problems with this too, seems to be a 0.11 thing.

Any suggestions for how to get UserManagerPlugin working again?

Attachments (1)

usermanagerplugin_problem.png (196.3 KB) - added by abalter 5 years ago.

Download all attachments as: .zip

Change History (9)

Changed 5 years ago by abalter

comment:1 Changed 5 years ago by abalter

Finally was able to remove and reinstall. Now getting this error:
http://myotherstuff.org/share/new_usermanagerplugin_problem.png

comment:2 Changed 5 years ago by anonymous

Hey abalter,

Looking at the attached image, I believe that the issue you're experiencing is related to acct_mngt plugin's config, and not usermanagerplugin.

Can you check if acct_mngt configured backend allows
actions like has_user() ?

ps

Thank you,
Catalin Balan

comment:3 Changed 5 years ago by abalter

Sorry about the authentication problem. You can see the stuff now.

comment:4 Changed 5 years ago by abalter

Hi Catalin,
I'm not much of an expert. I don't know how to "check if acct_mngt ... has_users()". Sorry. The account manager plugin is installed and works properly when it is enabled and the user manager plugin is disabled.

Perhaps now that you can see the outputs, you will be able to see the problem.
Thanks, Ariel

comment:5 Changed 5 years ago by abalter

I reinstalled. Now I'm back to this problem. Please help!
THX, abalter

p.s. the user profiles list macro is working (http://myotherstuff.org/heartstuff). Just the Admin>Users panel is broken. --AB

comment:6 Changed 5 years ago by abalter

Hi again,

I was able to fix the problem by disabling some features of the acct mgr plugin. Not sure exactly which one fixed it, and I don't want to mess around any further since it is working. Obviously, I needed to leave the login and authentication components.

A person who goes by "thatch" on the freenode trac IRC suggested the fix, and said he would like to work on the problem.

Just wanted to keep you updated.

Thanks, abalter

comment:7 follow-up: Changed 5 years ago by lkraav

doing some random housekeeping, is this problem solved or applicable even more? UserManagerPlugin seems to be running fine here on 0.11.6.

comment:8 in reply to: ↑ 7 Changed 3 years ago by ejucovy

  • Resolution set to worksforme
  • Status changed from new to closed

Replying to lkraav:

doing some random housekeeping, is this problem solved or applicable even more? UserManagerPlugin seems to be running fine here on 0.11.6.

This doesn't seem to be applicable any more, the plugin is running fine on 0.13-dev (aside from a few small bugs which are already being tracked separately)

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.