Modify

Opened 5 years ago

Closed 4 years ago

#5246 closed defect (invalid)

TypeError: iterable argument required

Reported by: jose.agnaldo@… Owned by: k0s
Priority: highest Component: TracHoursPlugin
Severity: blocker Keywords:
Cc: jose.agnaldo@…, jagnaldosousa@… Trac Release: 0.11

Description

How to Reproduce ¶

While doing a POST operation on /ticket/12, Trac issued an internal error.

Request parameters:

{'FORM_TOKEN': u'b1ac1bddd7453f7eaee2844a',

'action': u'resolve', 'action_resolve_resolve_resolution': u'Conclu\xeddo', 'cnum': u'12', 'comment': u, 'field_cc': u'carlos.andre, andre.martins, gilberto.lopes', 'field_component': u'SCAI', 'field_description': u'Cria\xe7\xe3o e ajustes do cronograma do projeto.\r\n\r\nPara efetuar estes levantamentos, siga a metodologia contida em 5Controlar?', 'field_dt_max_impl': u, 'field_estimatedhours': u'0', 'field_keywords': u, 'field_milestone': u'SCAI_5_Controlar', 'field_os_original': u, 'field_priority': u'Normal', 'field_qtd_horas_proj': u, 'field_reporter': u'jose.agnaldo', 'field_summary': u'Cronograma do sistema SCAI', 'field_ticket_pos': u'0 Iniciado', 'field_type': u'Outros', 'field_version': u, 'id': u'12', 'replyto': u, 'submit': u'Submit changes', 'ts': u'2009-05-18 15:10:30+00:00'}

User Agent was: Mozilla/5.0 (Windows; U; Windows NT 5.1; pt-BR; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10 System Information ¶ Trac 0.11.4 Python 2.4.3 (#1, Oct 23 2006, 14:19:47) [GCC 4.1.1 20060525 (Red Hat 4.1.1-1)] setuptools 0.6c9 SQLite 3.3.3 pysqlite 2.3.3 Genshi 0.5.1 mod_python 3.2.8 Pygments 0.11.1 Subversion 1.3.2 (r19776) jQuery: 1.2.6 Python Traceback ¶

Traceback (most recent call last):

File "/usr/lib/python2.4/site-packages/Trac-0.11.4-py2.4.egg/trac/web/main.py", line 435, in _dispatch_request

dispatcher.dispatch(req)

File "/usr/lib/python2.4/site-packages/Trac-0.11.4-py2.4.egg/trac/web/main.py", line 205, in dispatch

resp = chosen_handler.process_request(req)

File "/usr/lib/python2.4/site-packages/Trac-0.11.4-py2.4.egg/trac/ticket/web_ui.py", line 182, in process_request

return self._process_ticket_request(req)

File "/usr/lib/python2.4/site-packages/Trac-0.11.4-py2.4.egg/trac/ticket/web_ui.py", line 504, in _process_ticket_request

valid = self._validate_ticket(req, ticket) and not problems

File "/usr/lib/python2.4/site-packages/Trac-0.11.4-py2.4.egg/trac/ticket/web_ui.py", line 970, in _validate_ticket

for field, message in manipulator.validate_ticket(req, ticket):

File "/usr/lib/python2.4/site-packages/TracHoursPlugin-0.3.1-py2.4.egg/trachours/hours.py", line 234, in validate_ticket

can_add_hours = PermissionSystem(self.env).check_permission('TICKET_ADD_HOURS', user)

File "/usr/lib/python2.4/site-packages/Trac-0.11.4-py2.4.egg/trac/perm.py", line 425, in check_permission

perm)

File "build/bdist.linux-i686/egg/privatetickets/policy.py", line 32, in check_permission

TypeError: iterable argument required

Attachments (0)

Change History (1)

comment:1 Changed 4 years ago by AdrianFritz

  • Resolution set to invalid
  • Status changed from new to closed

Closing this ticket, because :

Feel free to reopen if the case.

Regards, Adrian

Add Comment

Modify Ticket

Action
as closed The owner will remain k0s.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.