Modify

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#5616 closed defect (fixed)

[Patch] Identical footnotes are not coalesced into one entry

Reported by: JoshuaH Owned by: rjollos
Priority: normal Component: FootNoteMacro
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

The documentation says that identical1 footnote references1 will be combined into a single footnote, but this doesn't seem to happen with the Trac 0.11 version of the plugin.

A patch that seems to fix this is attached.


  1. 1. like this

Attachments (1)

FootNoteMacro-Fix-collation.patch (2.1 KB) - added by JoshuaH 5 years ago.
Proposed patch

Download all attachments as: .zip

Change History (8)

Changed 5 years ago by JoshuaH

Proposed patch

comment:1 Changed 5 years ago by anonymous

  • Summary changed from Footnotes are not automatically collated in the 0.11 plugin to [Patch] Footnotes are not automatically collated in the 0.11 plugin

comment:2 Changed 5 years ago by rjollos

  • Owner changed from athomas to rjollos

Reassigning open tickets to myself since I am adopting this plugin.

comment:3 Changed 5 years ago by rjollos

  • Status changed from new to assigned

I'm seeing this behavior as well under Trac 0.12dev-r9098. I'll test out the patch.

comment:4 Changed 5 years ago by rjollos

  • Summary changed from [Patch] Footnotes are not automatically collated in the 0.11 plugin to [Patch] Identical footnotes are not collated in the 0.11 plugin

Clarification in comment:summary.

comment:5 Changed 5 years ago by rjollos

  • Summary changed from [Patch] Identical footnotes are not collated in the 0.11 plugin to [Patch] Identical footnotes are not coalesced into one entry

Further clarification in comment:summary.

comment:6 Changed 5 years ago by rjollos

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [7501]) Applied patch from JoshuaH to fix issue with identical footnotes not bing coalesced into one entry. Fixed #5616.

comment:7 Changed 5 years ago by rjollos

In case a future regression arises, here is the markup I used to reproduce this error and verify the fix after patching.

Testing out the th:FootNoteMacro [[FootNote(Here is the first
footnote)]]. This will be a good test[[FootNote(Here is the second
footnote)]]. And once again[[FootNote(Here is the second footnote)]]
[[FootNote(1)]].

Now I've test all of the documented behavior.

[[FootNote]]

We don't see this behavior on THO, presumably because it is running the 0.8 or 0.9 version of the plugin.


Testing out the th:FootNoteMacro 2. This will be a good test3. And once again3 1.

Now I've test all of the documented behavior.


  1. 2. Here is the first footnote
  2. 3. Here is the second footnote

Add Comment

Modify Ticket

Action
as closed The owner will remain rjollos.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.