Modify

Opened 5 years ago

Closed 5 years ago

#5654 closed defect (duplicate)

Preview and commit will not work if there have Chinese character in wiki pages

Reported by: wzuo@… Owned by: ivangsa
Priority: normal Component: WikiEditorForEclipsePlugin
Severity: normal Keywords: Chinese, unicode, preview, commit
Cc: Trac Release: 0.11

Description (last modified by ivangsa)

  1. If I composed a new wiki page in Chinese,when click preview tab,nothing will be displayed,just blank page,and this page can't be committed to server
  1. If I add some Chinese characters to the exist English page,the preview didnot work too,and I can't commit the page to server
  1. If the page only be composed in English,everything is ok.
  1. I got some error message from Trac server when I commit the page to the Trac server:
File "build/bdist.linux-i686/egg/tracrpc/web_ui.py", line 163, in process_request
    self.process_xml_request(req, content_type)
  File "build/bdist.linux-i686/egg/tracrpc/web_ui.py", line 167, in process_xml_request
    args, method = xmlrpclib.loads(req.read(int(req.get_header('Content-Length'))))
  File "/usr/lib/python2.5/xmlrpclib.py", line 1130, in loads
    p.feed(data)
  File "/usr/lib/python2.5/xmlrpclib.py", line 817, in end
    return f(self, join(self._data, ""))
  File "/usr/lib/python2.5/xmlrpclib.py", line 907, in end_value
    self.end_string(data)
  File "/usr/lib/python2.5/xmlrpclib.py", line 864, in end_string
    data = _decode(data, self._encoding)
  File "/usr/lib/python2.5/xmlrpclib.py", line 164, in _decode
    data = unicode(data, encoding)
  File "/usr/lib/python2.5/encodings/utf_8.py", line 16, in decode
    return codecs.utf_8_decode(input, errors, True)
UnicodeDecodeError: 'utf8' codec can't decode byte 0xd5 in position 1646: unexpected end of data

Attachments (0)

Change History (1)

comment:1 Changed 5 years ago by ivangsa

  • Description modified (diff)
  • Resolution set to duplicate
  • Status changed from new to closed

duplicate of #5653

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from ivangsa. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.