Modify

Opened 5 years ago

Closed 5 years ago

#5862 closed defect (duplicate)

Breaks XML-RPC plugins

Reported by: goldman Owned by: takanorig
Priority: normal Component: WorkflowEditorPlugin
Severity: normal Keywords:
Cc: dobesv@… Trac Release: 0.11

Description

Not 100% sure this is workfloweditor plugin's fault but with it disabled XML-RPC functions fine. This is the error thrown when RPC request comes in:

2009-09-23 02:42:44,207 Trac[main] ERROR: Internal Server Error:
Traceback (most recent call last):
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.11.5-py2.6.egg/trac/web/main.py", line 444, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.11.5-py2.6.egg/trac/web/main.py", line 175, in dispatch
    chosen_handler)
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.11.5-py2.6.egg/trac/web/main.py", line 295, in _pre_process_request
    chosen_handler = filter_.pre_process_request(req, chosen_handler)
  File "build/bdist.linux-i686/egg/dropbears/web_ui.py", line 18, in pre_process_request
    add_stylesheet(req, 'dropbear/dropbears.css')
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.11.5-py2.6.egg/trac/web/chrome.py", line 85, in add_stylesheet
    add_link(req, 'stylesheet', href(filename), mimetype=mimetype)
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.11.5-py2.6.egg/trac/web/chrome.py", line 61, in add_link
    linkset = req.chrome.setdefault('linkset', set())
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.11.5-py2.6.egg/trac/web/api.py", line 195, in __getattr__
    value = self.callbacks[name](self)
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.11.5-py2.6.egg/trac/web/chrome.py", line 489, in prepare_request
    for category, name, text in contributor.get_navigation_items(req):
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.11.5-py2.6.egg/trac/admin/web_ui.py", line 65, in get_navigation_items
    panels, providers = self._get_panels(req)
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.11.5-py2.6.egg/trac/admin/web_ui.py", line 161, in _get_panels
    p = list(provider.get_admin_panels(req))
  File "build/bdist.linux-i686/egg/workfloweditor/workfloweditor_admin.py", line 32, in get_admin_panels
    locale = LocaleUtil().get_locale(req)
  File "build/bdist.linux-i686/egg/workfloweditor/api.py", line 16, in get_locale
    if (len(locale_array) > 0):
TypeError: object of type 'NoneType' has no len()

Attachments (1)

workfloweditor_fix_TypeError.diff (545 bytes) - added by simohe@… 5 years ago.
Patch fixes this bug.

Download all attachments as: .zip

Change History (3)

comment:1 Changed 5 years ago by dobesv@…

  • Cc dobesv@… added

I get the same error when I attempt to use the trac-bitten build slave:

C:\Windows\system32>bitten-slave -v -u dobesv@habitsoft.com -P .../trac/builds
Passsword:
[INFO    ] Slave launched at 2009-10-06 09:35:30
[DEBUG   ] Enabling authentication with username 'dobesv@habitsoft.com'
[DEBUG   ] Performing basic/digest authentication
[DEBUG   ] Sending HEAD request to 'https://.../trac/login'
[DEBUG   ] Server returned error 500: Internal Server Error (Traceback (most recent call last):
  File "/usr/local/lib/python2.5/site-packages/Trac-0.11.3-py2.5.egg/trac/web/api.py", line 367, in send_error
    'text/html')
  File "/usr/local/lib/python2.5/site-packages/Trac-0.11.3-py2.5.egg/trac/web/chrome.py", line 708, in render_template
    data = self.populate_data(req, data)
  File "/usr/local/lib/python2.5/site-packages/Trac-0.11.3-py2.5.egg/trac/web/chrome.py", line 618, in populate_data
    d['chrome'].update(req.chrome)
  File "/usr/local/lib/python2.5/site-packages/Trac-0.11.3-py2.5.egg/trac/web/api.py", line 194, in __getattr__
    value = self.callbacks[name](self)
  File "/usr/local/lib/python2.5/site-packages/Trac-0.11.3-py2.5.egg/trac/web/chrome.py", line 476, in prepare_request
    for category, name, text in contributor.get_navigation_items(req):
  File "/usr/local/lib/python2.5/site-packages/Trac-0.11.3-py2.5.egg/trac/admin/web_ui.py", line 64, in get_navigation_i
tems
    panels, providers = self._get_panels(req)
  File "/usr/local/lib/python2.5/site-packages/Trac-0.11.3-py2.5.egg/trac/admin/web_ui.py", line 160, in _get_panels
    p = list(provider.get_admin_panels(req))
  File "build/bdist.linux-x86_64/egg/workfloweditor/workfloweditor_admin.py", line 32, in get_admin_panels
    locale = LocaleUtil().get_locale(req)
  File "build/bdist.linux-x86_64/egg/workfloweditor/api.py", line 16, in get_locale
    if (len(locale_array) > 0):
TypeError: object of type 'NoneType' has no len()
)
[ERROR   ] HTTP Error 500: Internal Server Error
[DEBUG   ] Removing working directory c:\users\dobes\appdata\local\temp\bittenzc47pb
[INFO    ] Slave exited at 2009-10-06 09:35:33

Changed 5 years ago by simohe@…

Patch fixes this bug.

comment:2 Changed 5 years ago by simohe@…

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #6645

patch for fixing is here or there

Add Comment

Modify Ticket

Action
as closed The owner will remain takanorig.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.