Modify

Opened 8 years ago

Closed 8 years ago

#603 closed defect (duplicate)

Permssion Error

Reported by: SEAN.HOWES@… Owned by: mgood
Priority: normal Component: AccountManagerPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.9

Description (last modified by coderanger)

When trying to register a new user I get the following error:

Oops...
Trac detected an internal error:

[Errno 13] Permission denied

If you think this really should work and you can reproduce it. Then you should consider to report this problem to the Trac team.

Go to http://trac.edgewall.com/ and create a new ticket where you describe the problem, how to reproduce it. Don't forget to include the python traceback found below.

TracGuide — The Trac User and Administration Guide
Python traceback

Traceback (most recent call last):
  File "/usr/lib64/python2.4/site-packages/trac/web/modpython_frontend.py", line 206, in handler
    dispatch_request(mpr.path_info, mpr, env)
  File "/usr/lib64/python2.4/site-packages/trac/web/main.py", line 139, in dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib64/python2.4/site-packages/trac/web/main.py", line 107, in dispatch
    resp = chosen_handler.process_request(req)
  File "build/bdist.linux-x86_64/egg/acct_mgr/web_ui.py", line 117, in process_request
  File "build/bdist.linux-x86_64/egg/acct_mgr/web_ui.py", line 138, in _do_create
  File "build/bdist.linux-x86_64/egg/acct_mgr/api.py", line 88, in set_password
  File "build/bdist.linux-x86_64/egg/acct_mgr/htfile.py", line 50, in set_password
  File "build/bdist.linux-x86_64/egg/acct_mgr/htfile.py", line 77, in _update_file
  File "/usr/lib64/python2.4/fileinput.py", line 231, in next
    line = self.readline()
  File "/usr/lib64/python2.4/fileinput.py", line 300, in readline
    os.rename(self._filename, self._backupfilename)
OSError: [Errno 13] Permission denied

I have tried changing the permisions on the password file but this has made no differnce if anone can please help it would be great

Attachments (0)

Change History (3)

comment:1 Changed 8 years ago by coderanger

  • Description modified (diff)
  • Summary changed from Account Manager Plugin to Permssion Error

Fixing title and formatting.

comment:2 Changed 8 years ago by coderanger

Make sure the user Trac is running as has write access to the folder containing the password file (not just the file itself).

comment:3 Changed 8 years ago by mgood

  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of #537. As coderanger said you need to provide write access to the password file and its parent directory. #537 was resolved to provide a better error message if write access was not available. If you're not seeing that message you're probably running an older version and should update your plugin.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.