Modify

Opened 8 years ago

Closed 8 years ago

#610 closed defect (worksforme)

Login error for multi project setup

Reported by: shawn Owned by: mgood
Priority: normal Component: AccountManagerPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.10

Description

I have 2 trac environment setup. First one is the production one and the second is for testing. When I update Trac to 0.10dev, I started to get errors when logging in. I then updated the AccountMananager to the right version for Trac 0.10dev. However, I still get an error. From close examination, it looks like AccountManager is looking in my test project for authentication when I'm actually trying to log into the production one. Check the following error:

If you think this really should work and you can reproduce it, you should consider reporting this problem to the Trac team.

Go to http://trac.edgewall.org/ and create a new ticket where you describe the problem, how to reproduce it. Don't forget to include the Python traceback found below.

TracGuide — The Trac User and Administration Guide 

Python Traceback
Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 335, in dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 191, in dispatch
    req.authname = self.authenticate(req)
  File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 145, in authenticate
    authname = authenticator.authenticate(req)
  File "/oci/trac/test/plugins/TracAccountManager-0.1.2.egg/acct_mgr/web_ui.py", line 160, in wrap
  File "/oci/trac/test/plugins/TracAccountManager-0.1.2.egg/acct_mgr/web_ui.py", line 167, in authenticate
  File "/oci/trac/test/plugins/TracAccountManager-0.1.2.egg/acct_mgr/web_ui.py", line 189, in _remote_user
  File "/oci/trac/test/plugins/TracAccountManager-0.1.2.egg/acct_mgr/api.py", line 94, in check_password
  File "/oci/trac/test/plugins/TracAccountManager-0.1.2.egg/acct_mgr/api.py", line 105, in password_store
TracError: No password store found.  Please configure "account-manager.password_format" in trac.ini.

Notice it the line containing "/oci/trac/test/plugins/TracAccountManager...". It should really be pointing to "/oci/trac/prod/plugins/TracAccountManager...".

Maybe there's a configuration that I need to set, but I can't seem to find it anywhere.

Attachments (0)

Change History (5)

comment:1 Changed 8 years ago by coderanger

  • Component changed from TracHacks to AccountManagerPlugin
  • Owner changed from athomas to matt_good

Retarget to correct component/person.

comment:2 Changed 8 years ago by coderanger

  • Owner changed from matt_good to mgood

Whoops, wrong username for this site.

comment:3 follow-up: Changed 8 years ago by shawn

  • Resolution set to fixed
  • Status changed from new to closed

Found out what's causing the problem.

I was trying to use easy_install to update the plugin but easy_install errored out. Didn't realize that it errored out until I examined the log file in greater detail.

After using svn to checkout the latest code from the trunk repository, I used python on the setup.py file to generate the distribution files. After copying the newly created plugin into the plugins directory and deleting the old one, it worked like a charm.

comment:4 in reply to: ↑ 3 Changed 8 years ago by mgood

  • Resolution fixed deleted
  • Status changed from closed to reopened

Replying to shawn:

Found out what's causing the problem.

I was trying to use easy_install to update the plugin but easy_install errored out. Didn't realize that it errored out until I examined the log file in greater detail.

Ok, good. I'm changing the resolution to worksforme, since fixed is used for things that required code changes.

comment:5 Changed 8 years ago by mgood

  • Resolution set to worksforme
  • Status changed from reopened to closed

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from mgood. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.