Modify

Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#6689 closed defect (invalid)

Theme not compatible with IE

Reported by: anonymous Owned by: Havok
Priority: normal Component: TseveTheme
Severity: critical Keywords:
Cc: Trac Release: 0.11

Description

Nice theme but does not work with IE (I checked v7 & v8 on different machines) - Menu structure has totally messed layout (i.e. tabs are displayed on right vertically)

Anyone can confirm / fix it?

Attachments (5)

IESS6.0.2900.5512.xpsp_sp3_gdr.090804-1435.jpg (138.2 KB) - added by slick666 4 years ago.
Screen Shot using IE 6.0.2900.5512.xpsp_sp3_gdr.090804-1435
IESS8.0.6001.18702.jpg (190.6 KB) - added by slick666 4 years ago.
Screen Shot using IE 8.0.6001.18702
FFSS3.5.3.jpg (217.7 KB) - added by slick666 4 years ago.
Screen Shot using FireFox 3.5.3
IE8-Compatibility_mode_off-1.png (393.2 KB) - added by Havok 4 years ago.
IE8-Compatibility_mode_off-2.png (281.5 KB) - added by Havok 4 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 5 years ago by Havok

True, I've tested it only with Gecko and Webkit based browsers.

If anyone can submit a path :D

Cheers

Changed 4 years ago by slick666

Screen Shot using IE 6.0.2900.5512.xpsp_sp3_gdr.090804-1435

comment:2 follow-up: Changed 4 years ago by slick666

  • Severity changed from normal to critical

I can confirm that I'm seeing the same thing. See IE 6.0 Screenshot for an example.

I've noticed that other theme also have problem with IE as well. Could this be a problem with the theme manager itself? or does this have do to with this theme specifically?

comment:3 in reply to: ↑ 2 Changed 4 years ago by Havok

Maybe I would add IE8 support... I really don't want to, but I feel some kind of responsibility towards Windows users. This theme is on production o a Intranet, where everybody uses Firefox, so, no problem there.

Again, if I add support to IE, It will be IE8, just forget about IE6 or IE7 because, because it's a pain in the *. That's why YouTube dropped the IE6 support, this browser needs to disappear.

Changed 4 years ago by slick666

Screen Shot using IE 8.0.6001.18702

comment:4 Changed 4 years ago by slick666

I agree IE 6.0 and even 7.0 are really old and think it's perfectly reasonable to work towards IE8 only. I've added a screen shot and you can see that it's just as bad and IE6.

I think that this theme won't see much adoption if it excludes all IE users. I, for example, would like to use this in a corporate setting where everything is windows and IE. If I can say that the site looks fine in IE8 but not the old IE 6 that some people have I think it would be perfectly acceptable to use.

What can be done to get this to work with IE?

Changed 4 years ago by slick666

Screen Shot using FireFox 3.5.3

comment:5 Changed 4 years ago by slick666

Added Firefox Screen Shot for others to show them how it should look.

Changed 4 years ago by Havok

Changed 4 years ago by Havok

comment:6 Changed 4 years ago by Havok

  • Resolution set to invalid
  • Status changed from new to closed

I Tested it with IE8 and it's compatible, so I'm closing this ticket.

sclick666, please turn off the "old compatibility mode" from your IE8, it's breaking everything, and it's like IE8 behave like IE6, and that browser needs to die for the sake of the internet.

I'm attaching a IE8 screenshot in normal mode, not "retro compatibility mode".

Cheers

comment:7 Changed 4 years ago by slick666

Thanks for the info, works for me too. I found out that you can turn compatibility mode off for intranet sites only.

Thanks

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.