Modify

Opened 5 years ago

Closed 2 years ago

#6794 closed defect (duplicate)

Traceback in apache error_log : "TypeError: issubclass() arg 1 must be a class"

Reported by: Samuel.Degrande@… Owned by: coderanger
Priority: normal Component: PermRedirectPlugin
Severity: normal Keywords:
Cc: pacopablo Trac Release: 0.11

Description

I have several Trac projects that are partly protected (some parts are publicly available).

When a public URL is accessed, I've got a Python Traceback in the apache error_logs files, which does however not prevent Trac to work (I only reproduce the last lines) :

[date...] [error] [client...] File "/usr/local/lib/python2.5/site-packages/trac/web/main.p
y", line 310, in _post_process_request\n    f.post_process_request(req, *(None,)*extra_arg_count)

[date...] [error] [client...] File "/pkgs/trac/distrib/usr/local/lib/python2.5/site-packag
es/TracPermRedirect-2.0-py2.5.egg/permredirect/filter.py", line 27, in post_process_request

[date...] [error] [client...] TypeError: issubclass() arg 1 must be a class

The attached patch seems to fix the error.

Attachments (1)

PermRedirectPlugin.patch (639 bytes) - added by Samuel.Degrande@… 5 years ago.

Download all attachments as: .zip

Change History (4)

Changed 5 years ago by Samuel.Degrande@…

comment:1 Changed 4 years ago by pacopablo

  • Cc pacopablo added; anonymous removed

Do you have any more detail on this? ie: What version of python, etc? I can not reproduce the error.

comment:2 Changed 4 years ago by Samuel.Degrande@…

Trac: 0.11.2.1 Python: 2.5.2 (r252:60911, Jun 3 2008, 12:24:45) [GCC 3.3.2] setuptools: 0.6c8 SQLite: 3.5.7 pysqlite: 2.3.2 Genshi: 0.5 mod_python: 3.3.1 Pygments: 0.11.1 Subversion: 1.5.0 (r31699) jQuery: 1.2.6

On Solaris 9.

Do you need some other details ?

comment:3 Changed 2 years ago by ejucovy

  • Resolution set to duplicate
  • Status changed from new to closed

Closing as a duplicate of #2194.

The patch looks harmless enough, but I can't reproduce the error. Are there certain URL paths that this occurs on?

If anyone can figure out how to reproduce it, or still sees this error in their logs, please comment on one of these two tickets.

Add Comment

Modify Ticket

Action
as closed The owner will remain coderanger.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.