Modify

Opened 4 years ago

Closed 4 years ago

#6947 closed defect (duplicate)

Error on create ticket after implement PrivateTicketsPlugin (TracHoursPlugin installed)

Reported by: wandi.ms@… Owned by: coderanger
Priority: high Component: PrivateTicketsPlugin
Severity: major Keywords:
Cc: Trac Release: 0.11

Description (last modified by rjollos)

After implement PrivateTicketsPlugin, whenever i create a ticket raise error message like this :

 Trac detected an internal error:

TypeError: argument of type 'NoneType' is not iterable


Python Traceback
Most recent call last:

File "/usr/lib/python2.6/dist-packages/trac/web/main.py", line 444, in _dispatch_request
  dispatcher.dispatch(req)
File "/usr/lib/python2.6/dist-packages/trac/web/main.py", line 205, in dispatch
  resp = chosen_handler.process_request(req)
File "/usr/lib/python2.6/dist-packages/trac/ticket/web_ui.py", line 183, in process_request
  return self._process_newticket_request(req)
File "/usr/lib/python2.6/dist-packages/trac/ticket/web_ui.py", line 400, in _process_newticket_request
  valid = self._validate_ticket(req, ticket)
File "/usr/lib/python2.6/dist-packages/trac/ticket/web_ui.py", line 970, in _validate_ticket
  for field, message in manipulator.validate_ticket(req, ticket):
File "/usr/local/lib/python2.6/dist-packages/TracHoursPlugin-0.5.2-py2.6.egg/trachours/ticket.py", line 45, in validate_ticket
  can_add_hours = PermissionSystem(self.env).check_permission('TICKET_ADD_HOURS', user)
File "/usr/lib/python2.6/dist-packages/trac/perm.py", line 425, in check_permission
  perm)
File "build/bdist.linux-i686/egg/privatetickets/policy.py", line 34, in check_permission

Attachments (0)

Change History (1)

comment:1 Changed 4 years ago by rjollos

  • Description modified (diff)
  • Resolution set to duplicate
  • Status changed from new to closed
  • Summary changed from Error on create ticket after implement PrivateTicketsPlugin to Error on create ticket after implement PrivateTicketsPlugin (TracHoursPlugin installed)

Duplicate of #5825, which I am currently working to resolve.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from coderanger. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.