Modify

Opened 4 years ago

Closed 4 years ago

Last modified 2 years ago

#7017 closed defect (fixed)

Can not see table headers - ver 0.12

Reported by: devexchage@… Owned by: walnut
Priority: normal Component: ChildTicketsPlugin
Severity: normal Keywords: table header setuptools
Cc: Trac Release: 0.11

Description (last modified by rjollos)

I have installed plugin for 0.12 version. I have added the following configuration:

[ticket-custom]
parent = text
parent.format = wiki
parent.label = Parent ID
[childtickets]
parent.bug.allow_child_tickets = true
parent.bug.default_child_type = bug
parent.bug.inherit_milestone = false
parent.bug.table_headers = type, priority, owner, summary, milestone

I have ticket type - bug.
When I am adding ticket I can fill in Parent ID field with corresponding value. The problem is that I can not see header table in the parent ticket.

Attachments (1)

Error.jpg (78.8 KB) - added by devexchage@… 4 years ago.

Download all attachments as: .zip

Change History (21)

Changed 4 years ago by devexchage@…

comment:1 Changed 4 years ago by walnut

  • Status changed from new to assigned

I've not had time to look at the plugin under Trac.0.12. I will try and take a look this weekend...

In the meantime, you might want to try itota's SubticketsPlugin plugin - it is tagged with '0.12' so might work better....

Will get back to you when I get chance to take a look.

comment:2 Changed 4 years ago by walnut

I've just taken a look at the jpg you attached. It looks to me as if the plugin itself is not correctly installed, can you check your trac.ini for the following section:

[components]
childtickets.* = enabled
childtickets.childtickets.tracchildticketsmodule = enabled

and that the plugin itself (Tracchildtickets-1.0.1-py2.6.egg) has been copied to the plugins directory of your trac repository.

Also, the [ticket-custom] section of the trac.ini file must have the following settings (ie. the link to the parent ticket comes from the 'parent.format = wiki' option!):

[ticket-custom]
parent = text
parent.format = wiki
parent.label = Parent ID

I have not used trac 0.12 myself yet, but I assume the 'Admin' tab still allows you to load, activate and deactivate plugins - is it correctly activated there?

I have also noticed that I must usually restart apache following the plugin install to get trac to see the changes - perhaps this helps too?

comment:3 follow-up: Changed 4 years ago by devexchage@…

I have used SubticketsPlugin plugin. But I wanted to try your one. It seems that yours provide more required information. The thing is that we are using py2.4. And all other plugins work fine with it. Maybe it can be the problem?

comment:4 Changed 4 years ago by walnut

In the latest revision of the plugin (changeset:7883), I have removed use of ternary operator which was only introduced at Python 2.5. This should make the plugin backwards compatible with Python 2.4.

However, I do not have a running instance of trac 0.12 yet, so I cannot say for certain whether this fixes the issue for trac 0.12.

Please let me know how it works....

comment:5 Changed 4 years ago by anonymous

@ devexchage :

Have you had chance to tet the changes yet? Can you let me know if it works in your environment...

comment:6 in reply to: ↑ 3 Changed 4 years ago by anonymous

Replying to devexchage@gmail.com:

I have used SubticketsPlugin plugin. But I wanted to try your one. It seems that yours provide more required information. The thing is that we are using py2.4. And all other plugins work fine with it. Maybe it can be the problem?

Hi - does this now work OK with Python 2.4? Are you still getting problems?

comment:7 follow-up: Changed 4 years ago by yoheeb@…

I have this "same" issue with 0.12. Do you happen to be running python 2.6? that is what gave me the issue. The import aborts looking for python >=2.5 for some reason:

2010-06-24 07:58:39,937 Trac[loader] DEBUG: Skipping "Tracchildtickets 1.0.2": ("DistributionNotFound: Python>=2.5" not found)
2010-06-24 07:58:39,937 Trac[loader] DEBUG: Loading childtickets from ...\python26\lib\site-packages\tracchildtickets-1.0.2-py2.6.egg
2010-06-24 07:58:39,953 Trac[loader] DEBUG: Skipping "childtickets = childtickets": ("DistributionNotFound: Python>=2.5" not found)

I have seen this before, but I forget where/why.

comment:8 in reply to: ↑ 7 Changed 4 years ago by anonymous

Replying to yoheeb@yahoo.com:

I have this "same" issue with 0.12. Do you happen to be running python 2.6? that is what gave me the issue. The import aborts looking for python >=2.5 for some reason:

2010-06-24 07:58:39,937 Trac[loader] DEBUG: Skipping "Tracchildtickets 1.0.2": ("DistributionNotFound: Python>=2.5" not found)
2010-06-24 07:58:39,937 Trac[loader] DEBUG: Loading childtickets from ...\python26\lib\site-packages\tracchildtickets-1.0.2-py2.6.egg
2010-06-24 07:58:39,953 Trac[loader] DEBUG: Skipping "childtickets = childtickets": ("DistributionNotFound: Python>=2.5" not found)

I have seen this before, but I forget where/why.

This is an issue with setuptools 0.6rc11 with the required python>=2.5 option. (for me, might be for you as well)

I believe there is a patch out there/the trunk version of setup tools would fix.
I personally was able to resolve this by removing that part from the setup.py file
and verify the plugin does work in 0.12 as is (works good too!)
to fix:

try upgrading setup tools to the latest version:

easy_install setuptools==dev06
or if you must go directly to the trunk:
http://svn.python.org/projects/sandbox/branches/setuptools-0.6/#egg=setuptools-dev06

finally, you could just modify setup to skip the python version check:

setup.py:

  • .py

    old new  
    1212    description = 'Provides support for pseudo child-tickets and a visual reference to these within a parent ticket.', 
    1313    keywords = 'trac plugins ticket dependency childtickets', 
    1414    url = 'http://trac-hacks.org/wiki/ChildTicketsPlugin', 
    15     install_requires = ['Trac >= 0.11', 'Genshi >= 0.5'], 
     15    install_requires = ['Trac>=0.11', 'Genshi>=0.5', 'Python>=2.5'], 
    1616    entry_points = """ 
    1717        [trac.plugins] 
    1818        childtickets = childtickets 

comment:9 follow-up: Changed 4 years ago by anonymous

  • Resolution set to fixed
  • Status changed from assigned to closed
  • Trac Release changed from 0.12 to 0.11

As recommended in the last comment, I have replaced the dependency on Python 2.5 with a minimum dependency on Python 2.4 in [8777]. This should allow it to compile with Python 2.4.

comment:10 follow-up: Changed 4 years ago by chitan@…

Hi i have same problem
I have trac 0.11.7 and Python 2.5
How can i fix this problem?

My trac.ini

[components]
childtickets.* = enabled
childtickets.childtickets.tracchildticketsmodule = enabled

parent = text
parent.format = wiki
parent.label = Parent ID

[childtickets]

# 'enhancements' : child tickets will typically be bug-fix tickets with the same milestone.
parent.enhancement.allow_child_tickets = true
parent.enhancement.table_headers = type, status, owner, summary
parent.enhancement.default_child_type = bug-fix
parent.enhancement.restrict_child_type = bug-fix, task
parent.enhancement.inherit_milestone = true

# 'bug-report' : child tickets will typically be bug-fix
parent.bug-report.allow_child_tickets = true
parent.bug-report.default_child_type = bug-fix
parent.bug-report.table_headers = type, priority, owner, summary, milestone
parent.bug-report.inherit_milestone = true

# 'issue' : child tickets will typically be task tickets with no default milestone.
parent.issue.allow_child_tickets = true
parent.issue.default_child_type = task
parent.issue.table_headers = type, status, owner, summary, milestone
parent.issue.inherit_milestone = false

# 'bug-fix' : child tickets are not allowed.
parent.bug-fix.allow_child_tickets = true

# 'task' : child tickets are not allowed.
parent.task.allow_child_tickets = true

comment:11 follow-up: Changed 4 years ago by anonymous

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:12 in reply to: ↑ 10 Changed 4 years ago by walnut

Replying to chitan@mail.ru:

Hi i have same problem
I have trac 0.11.7 and Python 2.5
How can i fix this problem?

My trac.ini

[components]
childtickets.* = enabled
childtickets.childtickets.tracchildticketsmodule = enabled

parent = text
parent.format = wiki
parent.label = Parent ID

[childtickets]

# 'enhancements' : child tickets will typically be bug-fix tickets with the same milestone.
parent.enhancement.allow_child_tickets = true
parent.enhancement.table_headers = type, status, owner, summary
parent.enhancement.default_child_type = bug-fix
parent.enhancement.restrict_child_type = bug-fix, task
parent.enhancement.inherit_milestone = true

# 'bug-report' : child tickets will typically be bug-fix
parent.bug-report.allow_child_tickets = true
parent.bug-report.default_child_type = bug-fix
parent.bug-report.table_headers = type, priority, owner, summary, milestone
parent.bug-report.inherit_milestone = true

# 'issue' : child tickets will typically be task tickets with no default milestone.
parent.issue.allow_child_tickets = true
parent.issue.default_child_type = task
parent.issue.table_headers = type, status, owner, summary, milestone
parent.issue.inherit_milestone = false

# 'bug-fix' : child tickets are not allowed.
parent.bug-fix.allow_child_tickets = true

# 'task' : child tickets are not allowed.
parent.task.allow_child_tickets = true

Hi 'chitan@…'

Your trac.ini file is missing the following section header for the 'ticket-custom' parent ticket number. (See : http://trac.edgewall.org/wiki/TracTicketsCustomFields). It should look like this:

[ticket-custom]
parent = text
parent.format = wiki
parent.label = Parent ID

If that doesn't help, consider the following points....

You also need to ensure that the ticket types listed in the configuration section (parent.<type>.xxx) are also defined for your environment ('Admin'->'Ticket Types'->'Add Ticket Types').
(If you are using the 'default' ticket types, try creating a ticket of type 'enhancement' and see whether the child ticket section appears then...)

If you are still having problems, set the debug level to 'DEBUG' in trac.ini and check the plugin is being loaded.
You should see a line that says:

2010-09-27 14:30:42,892 Trac[loader] DEBUG: Adding plugin Tracchildtickets 1.0.3 from .../plugins/Tracchildtickets-1.0.3-py2.6.egg

If you see that it is being loaded and still don't see anything, then send me following info:

  • list of other plugins installed
  • list of ticket types defined in your environment
  • output from the trac log file with 'log_level' set to 'DEBUG'

Finally, have you or anyone else made change to the 'ticket.html' file that defines the ticket itself. This plugin uses a stream filter to modify this on the fly - obviously this won't work if the ticket.html file has been modified somehow.....

Speak soon.
Regards
Mark

comment:13 in reply to: ↑ 11 Changed 4 years ago by walnut

Replying to anonymous:

Hi devexchage@…

Are you still having problems yourself with this plugin or is it working for you now?

If it is still not working, could you also send me output from your trac log file (with log_level set to 'debug')

Thanks

comment:14 follow-up: Changed 4 years ago by rjollos

  • Description modified (diff)

comment:15 in reply to: ↑ 14 Changed 4 years ago by walnut

Replying to rjollos:

Hi,

Can you try the following for me.... in the 'trac.ini' file, set the log_level to 'debug' and output to a suitable file:

[logging]
log_file = /tmp/trac.log
log_level = DEBUG
log_type = file

Can you confirm that the plugin is even being loaded, I see the following line in my 'trac.log' file with the above settings:

2010-09-29 21:53:13,348 Trac[env] INFO: -------------------------------- environment startup [Trac 0.12] --------------------------------
2010-09-29 21:53:13,413 Trac[loader] DEBUG: Adding plugin Tracchildtickets 1.0.3 from /xxx/trac/testenv/plugins/Tracchildtickets-1.0.3-py2.6.egg

If you do see this then the plugin is obviously being loaded and the problem lies somewhere else! Could you include a list of other plugins that are installed.

Thanks

comment:16 Changed 4 years ago by anonymous

Just another thought....

I always install the plugins locally in every environment. If you do this, then (I believe) you do not need to specify the plugin in the '[components]' section of 'trac.ini'.

If you have the plugin in a global plugins directory ('[inherit]' section of the 'trac.ini'), then you need to explicitly load the plugin:

[components]
childtickets.* = enabled
childtickets.childtickets.tracchildticketsmodule = enabled

comment:17 in reply to: ↑ 9 ; follow-up: Changed 4 years ago by anonymous

Replying to anonymous:

As recommended in the last comment, I have replaced the dependency on Python 2.5 with a minimum dependency on Python 2.4 in [8777]. This should allow it to compile with Python 2.4.

This change did not fix it. I'm not sure why, since it seems fine to me. But, I just tried to install this on py2.4 and got this error:

Trac[loader] DEBUG: Skipping "Tracchildtickets 1.0.5": ("DistributionNotFound: Python>=2.4" not found)

I fixed it by removing the python check altogether as suggested in comment 8

comment:18 in reply to: ↑ 17 Changed 4 years ago by anonymous

Replying to anonymous:

I fixed it by removing the python check altogether as suggested in comment 8

Do you think the problem was with the setuptools as described in comment 8 ...??

comment:19 Changed 4 years ago by anonymous

  • Resolution set to fixed
  • Status changed from reopened to closed

I see there has been no replies or further comments to this issue for some time now - I assume issues have been resolved - so I shall close the ticket. If this is still a live issue please reopen with further info as requested above (comment:15)

comment:20 Changed 2 years ago by rjollos

  • Keywords setuptools added

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.