Modify

Opened 4 years ago

Closed 4 years ago

#7254 closed defect (duplicate)

AttributeError: 'TracError' object has no attribute 'acctmgr' - when creating new user in web admin UI

Reported by: mcpbalaji@… Owned by: mgood
Priority: normal Component: AccountManagerPlugin
Severity: normal Keywords: unicode change notify
Cc: rjollos Trac Release: 0.11

Description

How to Reproduce ¶

While doing a POST operation on /admin/accounts/users, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'FORM_TOKEN': u'83c0a3343386eedf9340e618',

'add': u' Add ',
'cat_id': u'accounts',
'email': u'balajiv@…',
'name': u'BalajiV',
'panel_id': u'users',
'password': u'xerago123',
'password_confirm': u'xerago123',
'path_info': None,
'user': u'admin2'}

User Agent was: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.5) Gecko/2008121911 CentOS/3.0.5-1.el5.centos Firefox/3.0.5
System Information ¶
Trac 0.11
Python 2.5.2 (r252:60911, Jul 22 2009, 15:52:25)
[GCC 4.2.4 (Ubuntu 4.2.4-1ubuntu3)]
setuptools 0.6c11
SQLite 3.4.2
pysqlite 2.3.2
Genshi 0.6
mod_python 3.3.1
Subversion 1.4.6 (r28521)
jQuery: 1.2.3
Python Traceback ¶

Traceback (most recent call last):

File "/usr/lib/python2.5/site-packages/Trac-0.11-py2.5.egg/trac/web/main.py", line 423, in _dispatch_request

dispatcher.dispatch(req)

File "/usr/lib/python2.5/site-packages/Trac-0.11-py2.5.egg/trac/web/main.py", line 197, in dispatch

resp = chosen_handler.process_request(req)

File "/usr/lib/python2.5/site-packages/Trac-0.11-py2.5.egg/trac/admin/web_ui.py", line 109, in process_request

path_info)

File "build/bdist.linux-i686/egg/acct_mgr/admin.py", line 117, in render_admin_panel

return self._do_users(req)

File "build/bdist.linux-i686/egg/acct_mgr/admin.py", line 191, in _do_users

dataacctmgr? = e.acctmgr

AttributeError: 'TracError' object has no attribute 'acctmgr

Please help me...

Attachments (0)

Change History (2)

comment:1 Changed 4 years ago by qiuguo0205@…

I reproduce the problem when I use Trac too. And I found it is because some Chinese characters are added in the project's description in the Admin page. If I delete the Chinese characters, the problem is solved.

The exact position that Chinese characters are added is "管理—>一般—>基础设置—>描述"; I guess in English it is in "Admin—>General—>Basic—>Description".

Hope this could help to trace your problem.

comment:2 Changed 4 years ago by hasienda

  • Cc rjollos added
  • Keywords unicode change notify added
  • Resolution set to duplicate
  • Status changed from new to closed
  • Summary changed from while creatind the users in web ui getting error. to AttributeError: 'TracError' object has no attribute 'acctmgr' - when creating new user in web admin UI

Thank you for the elaborated error description. It holds some unique information, that could lead us towards a solution.

Anyway looks like another variant of #4040, so I'll better close this one as well as #7063 and #7147 before, just reference it and add you to Cc-list over there.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from mgood. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.