Modify

Opened 8 years ago

Closed 8 years ago

#731 closed defect (worksforme)

TRAC_ENV necessary ...

Reported by: ThurnerRupert Owned by: coderanger
Priority: high Component: TracForgePlugin
Severity: blocker Keywords:
Cc: Trac Release: 0.10

Description

we have multiple trac instances and set the environment with mod python in apache like:

PythonOption TracEnvParentDir /var/trac-parentdir

this leads to the error:

Traceback (most recent call last):
  File "/usr/local/lib/python2.4/site-packages/trac/web/main.py", line 356, in dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/lib/python2.4/site-packages/trac/web/main.py", line 189, in dispatch
    req.authname = self.authenticate(req)
  File "/usr/local/lib/python2.4/site-packages/trac/web/main.py", line 145, in authenticate
    authname = authenticator.authenticate(req)
  File "/usr/local/lib/python2.4/site-packages/trac/web/auth.py", line 64, in authenticate
    authname = self._get_name_for_cookie(req, req.incookie['trac_auth'])
  File "build/bdist.solaris-2.8-sun4u/egg/tracforge/linker/auth.py", line 38, in _get_name_for_cookie
  File "build/bdist.solaris-2.8-sun4u/egg/tracforge/linker/auth.py", line 20, in <lambda>
  File "/usr/local/lib/python2.4/site-packages/trac/web/main.py", line 57, in _open_environment
    env_cache[env_path] = open_environment(env_path)
  File "/usr/local/lib/python2.4/site-packages/trac/env.py", line 429, in open_environment
    raise TracError, 'Missing environment variable "TRAC_ENV". Trac ' \
TracError: Missing environment variable "TRAC_ENV". Trac requires this variable to point to a valid Trac environment.

Attachments (0)

Change History (1)

comment:1 Changed 8 years ago by coderanger

  • Resolution set to worksforme
  • Status changed from new to closed

This error is caused by not setting your master_path. It should give a better error since the last changeset.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from coderanger. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.