Modify

Opened 4 years ago

Closed 2 years ago

#7317 closed defect (fixed)

[Patch] currentTab = ui.panel.id; is undefined for workfloweditor.js (line 67) on Trac-0.12

Reported by: anonymous Owned by: rjollos
Priority: normal Component: WorkflowEditorPlugin
Severity: normal Keywords:
Cc: klaux1@… Trac Release: 0.12

Description

Hello workfloweditor team!

The textTab of this plugins don't function on Trac-0.12. My FireBug speak this:

reference to undefined property this.options[type]
    currentTab = ui.panel.id;        workfloweditor.js (linha 67)
reference to undefined property ui.panel
    currentTab = ui.panel.id;        workfloweditor.js (linha 67)
ui.panel is undefined
    currentTab = ui.panel.id;        workfloweditor.js (linha 67)

About My Trac

Informação do Sistema
Trac 	0.12
Babel 	0.9.5
CustomFieldAdmin 	0.2.2
FullBlog 	0.1.1-r7969
Genshi 	0.6
mod_python 	3.3.1
pysqlite 	2.3.2
Python 	2.5.2 (r252:60911, Jan 24 2010, 15:24:24) [GCC 4.3.2]
RPC 	1.1.0-r7971
setuptools 	0.6c11
SQLite 	3.5.9
Subversion 	1.5.1 (r32289)
jQuery:	1.4.2
Plugins Instalados
AnnouncerPlugin 	0.2 	/usr/lib/python2.5/site-packages/AnnouncerPlugin-0.2-py2.5.egg
IniAdmin 	0.2 	/usr/lib/python2.5/site-packages/IniAdmin-0.2-py2.5.egg
SvnAuthzAdminPlugin 	0.1.2.-Moved.to.Trac.0.11- 	/usr/lib/python2.5/site-packages/SvnAuthzAdminPlugin-0.1.2._Moved.to.Trac.0.11_-py2.5.egg
TracCAS 	2.0.1 	/usr/lib/python2.5/site-packages/TracCAS-2.0.1-py2.5.egg
TracCondFields 	2.0 	/usr/lib/python2.5/site-packages/TracCondFields-2.0-py2.5.egg
TracCustomFieldAdmin 	0.2.2 	/usr/lib/python2.5/site-packages/TracCustomFieldAdmin-0.2.2-py2.5.egg
TracFullBlogPlugin 	0.1.1-r7969 	/usr/lib/python2.5/site-packages/TracFullBlogPlugin-0.1.1_r7969-py2.5.egg
TracNav 	4.2.dev-r3275 	/usr/lib/python2.5/site-packages/TracNav-4.2.dev_r3275-py2.5.egg
TracUserManagerPlugin 	0.4 	/usr/lib/python2.5/site-packages/TracUserManagerPlugin-0.4-py2.5.egg
TracWysiwyg 	0.2-r7772 	/usr/lib/python2.5/site-packages/TracWysiwyg-0.2_r7772-py2.5.egg
TracXMLRPC 	1.1.0-r7971 	/usr/lib/python2.5/site-packages/TracXMLRPC-1.1.0_r7971-py2.5.egg
WorkflowEditorPlugin 	1.0.2-r6348 	/usr/lib/python2.5/site-packages/WorkflowEditorPlugin-1.0.2_r6348-py2.5.egg

Thx for all

Attachments (2)

workfloweditorplugin_0.11_r6348.diff (889 bytes) - added by klaux1@… 4 years ago.
("Hello? Hello? Anybody home?" :-) Friends, the patch in attachment solves my problem.
workfloweditorplugin-0.12-r9979.diff (1.9 KB) - added by jun66j5 3 years ago.

Download all attachments as: .zip

Change History (14)

Changed 4 years ago by klaux1@…

("Hello? Hello? Anybody home?" :-) Friends, the patch in attachment solves my problem.

comment:1 Changed 4 years ago by klaux1@…

I'm waiting the project leader close this ticket or correct my patch.

Thx

comment:2 follow-up: Changed 4 years ago by rjollos

  • Summary changed from currentTab = ui.panel.id; is undefined for workfloweditor.js (line 67) on Trac-0.12 to [Patch] currentTab = ui.panel.id; is undefined for workfloweditor.js (line 67) on Trac-0.12

I don't see any active development on this plugin in some time. If no response from the plugin author in 2 weeks time, please reply here and i'll apply the patch.

comment:3 in reply to: ↑ 2 ; follow-up: Changed 3 years ago by klaux1@…

Replying to rjollos:

I don't see any active development on this plugin in some time. If no response from the plugin author in 2 weeks time, please reply here and i'll apply the patch.

Hello Friend! Can You apply the patch on the trunk!?

Thx.
--
KlauX

comment:4 in reply to: ↑ 3 Changed 3 years ago by rjollos

  • Owner changed from takanorig to rjollos
  • Status changed from new to assigned

Replying to klaux1@yahoo.com.br:

Hello Friend! Can You apply the patch on the trunk!?

Yes, thank you for the reminder. I'll apply now. Please test it out and report back here, if possible.

comment:5 Changed 3 years ago by rjollos

(In [9974]) The 0.11 branch is now the 0.12 branch. Refs #7317.

comment:6 Changed 3 years ago by rjollos

(In [9975]) Branch 0.12 to create a new 0.11 branch. Refs #7317.

comment:7 Changed 3 years ago by rjollos

Patch was missing a closing bracket, but otherwise seems to fix the issue under Trac 0.12. Under Trac 0.11, I don't see this issue, so I'm only applying the fix to the 0.12 branch.

comment:8 Changed 3 years ago by rjollos

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [9978]) Fix for not being able to switch from the Grid to Text tab under Trac 0.12. Fixes #7317.

comment:9 follow-ups: Changed 3 years ago by jun66j5

  • Resolution fixed deleted
  • Status changed from closed to reopened

The issue is not fixed. It's able to switch to the Text tab, however the changes (e.g. changing the name of action) on the Grid tab is not reflected to the Text tab.

I worked and attach the new patch, workfloweditorplugin-0.12-r9979.diff. Please the patch, if you can.

Changed 3 years ago by jun66j5

comment:10 in reply to: ↑ 9 Changed 3 years ago by jun66j5

Replying to jun66j5:

I worked and attach the new patch, workfloweditorplugin-0.12-r9979.diff. Please the patch, if you can.

I tested with IE 6-8 and Firefox 3.6.x.
When Firefox 4, it doesn't work with another problem. I will create new ticket to report it later.

comment:11 in reply to: ↑ 9 Changed 2 years ago by rjollos

Replying to jun66j5:

I worked and attach the new patch, workfloweditorplugin-0.12-r9979.diff. Please the patch, if you can.

jun66j5, sorry, I lost track of this ticket. I'll push the change now.

comment:12 Changed 2 years ago by rjollos

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [11390]) Fixes #7317, #9670: Fix for changes not applied before switching to the text tab. Thanks to jun66j5 for the patch. Tested with Trac 0.12.0.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.