Modify

Opened 4 years ago

Closed 4 years ago

#7401 closed defect (duplicate)

HtPasswdStore mode: update to passwd file changes files group

Reported by: anonymous Owned by: mgood
Priority: high Component: AccountManagerPlugin
Severity: normal Keywords: htpasswd mangle file permission
Cc: Trac Release: 0.11

Description

This problem is particularly a problem if a the setup is on Dreamhost. Following this tutorial almost allows this plugin to be used flawlessly: http://wiki.dreamhost.com/Troubleshoot_Trac_One-Click_Install. However, when any change is made to the password, the htpasswd file's group ownership is changed from dhapache to the group that the user is a part of (i.e. pg*). I don't know the inner workings of this plugin, but am starting to look into them more to see if I can see why this is happening. The file is writable, so it should be able to be edited while keeping the group ownership unchanged.

This essentially crashes the installation until you manually get it changed back either by a Dreamhost admin, and one other method through the Dreamhost panel.

If I need to clarify on this more, please let me know. This may just be a limitation of the plugin that can't be changed, but I'd like to be sure.

I.e.

Before password changed through plugin
-rw-r----- 1 theuser dhapache 154 2010-07-21 10:00 thefile.passwd

After password changed through plugin
-rw-r----- 1 theuser pg* 154 2010-07-21 10:00 thefile.passwd

Thanks,
Andrew

Attachments (0)

Change History (2)

comment:1 Changed 4 years ago by anonymous

  • Severity changed from major to normal

Okay...found out that the problem is not the plugin, but rather python itself. I suspected this, but wasn't sure until now. Apparently it's been like this for awhile (found someone complaining of it back in 1999). I'm going to see if I can port over the solution someone proposed for version 1.5 of python to the current version... I'll also continue searching for other methods of fixing this...

http://mail.python.org/pipermail/python-bugs-list/1999-October/000221.html

http://stackoverflow.com/questions/1605288/python-fileinput-changes-permission

I don't think the solution in the second link will work because the group to switch back to is dhapache (only Dreamhost admins can chown to that)...I'll try it anyways though.

comment:2 Changed 4 years ago by hasienda

  • Keywords htpasswd mangle file permission added
  • Resolution set to duplicate
  • Status changed from new to closed

See #4276, as there is already a proposed solution.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.