Modify

Opened 4 years ago

Closed 19 months ago

#7460 closed defect (fixed)

Wrong schema definition for PostgreSQL

Reported by: mitar Owned by: coderanger
Priority: normal Component: MasterTicketsPlugin
Severity: normal Keywords:
Cc: mmitar@… Trac Release: 0.11

Description

Schema defintion for mastertickets table is not precise and so plugin fails on PostgreSQL with:

ProgrammingError: operator does not exist: text = integer
LINE 1: SELECT dest FROM mastertickets WHERE source=32 ORDER BY dest
                                                   ^
HINT:  No operator matches the given name and argument type(s). You might need to add explicit type casts.

This select query is in:

 File "/usr/lib/pymodules/python2.5/mastertickets/model.py", line 22, in  __init__  

The problem is that columns are not defined with integer type. I am attaching a patch which fixes this.

Attachments (1)

schema_types.patch (421 bytes) - added by mitar 4 years ago.

Download all attachments as: .zip

Change History (2)

Changed 4 years ago by mitar

comment:1 Changed 19 months ago by rjollos

  • Resolution set to fixed
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from coderanger. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.