Modify

Opened 4 years ago

Closed 3 years ago

#7514 closed defect (fixed)

Reformatting misses edited ticket comments

Reported by: dnedelchev Owned by: mrelbe
Priority: normal Component: TracTicketChangesetsPlugin
Severity: normal Keywords: edit reformat
Cc: Trac Release: 0.12

Description (last modified by rjollos)

I found that tracopt-stile macros are neither listed by diff command nor updated by reformat command for edited comments. While other untouched comments in the same message (containing tracopt-stile macros too) are processed as expected.
That can be seen on the screenshot I'm attaching: Comment 2 (concerning Revision 100) was edited manually before reformatting and Comment 3 (concerning Revision 101) was not. Comment 3 is upgraded and Comment 2 is not. Hence the error message is raised when tracopt/CommitTicketReferenceMacro is disabled.

Attachments (1)

reformatting_edited_comment.png (7.8 KB) - added by dnedelchev 4 years ago.

Download all attachments as: .zip

Change History (5)

Changed 4 years ago by dnedelchev

comment:3 Changed 4 years ago by rjollos

#7513 is a duplicate. I'll leave this ticket open since it has additional info.

comment:4 Changed 4 years ago by rjollos

  • Description modified (diff)
  • Summary changed from reformatting misses edited ticket comments to Reformatting misses edited ticket comments

comment:5 Changed 4 years ago by mrelbe

  • Status changed from new to assigned

This observation is probably correct -- I forgot to implement a conversion for "0.12-style comments" since I myself went from Trac 0.11 to 0.12 in connection to applying this plugin for all of my databases.

Thanks for finding this.

comment:4 Changed 3 years ago by mrelbe

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [10001]) Fixed #7514: Reformatting misses edited ticket comments

The problem is even worse: historical content of ticket comments is destroyed in the database and makes Trac crash... (concerns Trac 0.12 which allows editing of ticket comments).

This is now fixed.

(I'm so sorry for the ridiculous long delay in fixing this.)

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from mrelbe. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.