Modify

Opened 4 years ago

Closed 2 years ago

#7619 closed defect (duplicate)

cannot add comment to newly created tickets (ValueError: need more than 1 value to unpack)

Reported by: mklerk@… Owned by: superafroman
Priority: normal Component: TicketValidatorPlugin
Severity: blocker Keywords:
Cc: Trac Release: 0.12

Description (last modified by rjollos)

I created a new ticket workflow with a triage on the first ticket state using AdvancedTicketWorkflowPlugin. (see workflow below)

How to reproduce:

  1. Submit a new ticket
  2. Try to add a comment to it.

I get the following error message:

Trac detected an internal error: ValueError: need more than 1 value to unpack

Note that the following plugins seem to be involved: ticketvalidator.core, AdvancedTicketWorkflowPlugin Please report this issue to the plugin maintainer.

After disabling the TicketvalidatorPlugin the problem was solved.

Workflow:
[ticket-workflow]
accept = entered,assigned,accepted,reopened -> accepted
accept.operations = set_owner_to_self
accept.permissions = TICKET_MODIFY
close = service,resolved,testing,in_review -> closed
close.permissions = TICKET_ADMIN
in_review_reassign = in_review -> assigned
in_review_reassign.name = reassign to resolver
in_review_reassign.operations = set_owner_to_previous, set_resolution
in_review_reassign.permissions = TICKET_ADMIN
in_review_reassign.set_resolution = Resolution Failed
in_review_retest = in_review -> testing
in_review_retest.name = reassign to tester
in_review_retest.operations = set_owner, set_resolution
in_review_retest.permissions = TICKET_ADMIN
in_review_retest.set_resolution = Resolved
leave = * -> *
leave.default = 1
leave.operations = leave_status
reassign = entered,assigned,accepted,reopened -> assigned
reassign.operations = set_owner
reassign.permissions = TICKET_MODIFY
reopen = closed -> reopened
reopen.operations = del_resolution, set_owner
reopen.permissions = TICKET_ADMIN
resolve = assigned,accepted,reopened -> resolved
resolve.operations = set_resolution
resolve.permissions = TICKET_MODIFY
resolve.set_resolution = Resolved
submit = new -> *
submit.name = Accept ticket into workflow
submit.operations = triage
submit.triage_field = type
submit.triage_split = SC (Service Call)-> service,PR (Problem Report) -> entered, CR (Change Request) -> entered
submit.permissions = TICKET_MODIFY
test_accept = resolved -> testing
test_accept.name = Testen
test_accept.operations = set_owner_to_self
test_fail = testing -> assigned
test_fail.name = test failed
test_fail.operations = set_resolution, set_owner_to_previous
test_fail.permissions = TICKET_MODIFY
test_fail.set_resolution = Resolution Failed
test_ok = testing -> in_review
test_ok.name = test OK
test_ok.permissions = TICKET_MODIFY

Log:
File "build/bdist.linux-i686/egg/trac/web/main.py", line 513, in _dispatch_request
  dispatcher.dispatch(req)
File "build/bdist.linux-i686/egg/trac/web/main.py", line 235, in dispatch
  resp = chosen_handler.process_request(req)
File "build/bdist.linux-i686/egg/trac/ticket/web_ui.py", line 169, in process_request
  return self._process_ticket_request(req)
File "build/bdist.linux-i686/egg/trac/ticket/web_ui.py", line 534, in _process_ticket_request
  valid = self._validate_ticket(req, ticket, not valid) and valid
File "build/bdist.linux-i686/egg/trac/ticket/web_ui.py", line 1179, in _validate_ticket
  for field, message in manipulator.validate_ticket(req, ticket):
File "/usr/lib/python2.5/site-packages/TicketValidator-0.1-py2.5.egg/ticketvalidator/core.py", line 53, in validate_ticket
  state = self._get_state(req, ticket)
File "/usr/lib/python2.5/site-packages/TicketValidator-0.1-py2.5.egg/ticketvalidator/core.py", line 74, in _get_state
  action_changes.update(controller.get_ticket_changes(req, ticket, action))
File "build/bdist.linux-i686/egg/advancedworkflow/controller.py", line 349, in get_ticket_changes
  return {'status': self._new_status(ticket, action)}
File "build/bdist.linux-i686/egg/advancedworkflow/controller.py", line 358, in _new_status
  value, status = [y.strip() for y in transition.split('->')]

Attachments (0)

Change History (3)

comment:1 Changed 4 years ago by rjollos

  • Description modified (diff)

comment:2 Changed 3 years ago by anonymous

For a solution, see ticket #9554.

comment:3 Changed 2 years ago by rjollos

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #4807.

Add Comment

Modify Ticket

Action
as closed The owner will remain superafroman.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.