Modify

Opened 4 years ago

Closed 14 months ago

#7815 closed defect (duplicate)

DateField-1.0.1 doesn't MODIFY customfield in TracCustomFieldAdmin-0.2.5

Reported by: shentonfreude Owned by: rjollos
Priority: normal Component: DateFieldPlugin
Severity: normal Keywords:
Cc: snoopotic@… Trac Release: 0.12

Description (last modified by rjollos)

I've installed both DateField-1.0.1 and TracCustomFieldAdmin-0.2.5 and enabled DateFieldModule and CustomFieldAdminTweak. If I create a new custom field I can pick a Date type and allow empty value, excellent.

But if I try to modify an existing field -- e.g., from Text to Date -- it gives me the proper UI but does not save the new field to the trac.ini with

  myfield.date = true
  myfield.date_empty = on

like the field newly created after the DateFieldPlugin was installed.

I notice that the Submit causes the trac.ini file to rewrite my [datefield] section (e.g. re-ordering the fields) so something's changing but it doesn't change the desired field properties and reports no error.

I can edit the trac.ini by hand and add those fields and it works fine however.

Attachments (0)

Change History (6)

comment:1 Changed 4 years ago by shentonfreude

Also, If I try and modify a custom field successfully created by DateField and TracCustomFieldAdmin, the edit pane shows the type as Text (not Date) and a subsequent save converts it to a plain Text field -- it loses its dateliness.

comment:2 Changed 3 years ago by rjollos

  • Description modified (diff)

comment:3 Changed 2 years ago by snoopotic

  • Cc snoopotic@… added

I can confirm that for CustomFieldAdmin 0.2.6.-r10460 and DateField 1.0.2-r10435 on trac 0.12.2, it also happens if you modify a already successfuly created date- 'custom field' (e.g. on admin/ticket/customfields/date_field)

After clicking 'save' the two lines:

<customfield name>.date = true
<customfield name>.date_empty = on

get deleted from trac.ini.

comment:4 Changed 22 months ago by rjollos

  • Description modified (diff)
  • Owner changed from doki_pen to rjollos
  • Status changed from new to assigned

comment:5 Changed 14 months ago by rjollos

  • Status changed from assigned to new

comment:6 Changed 14 months ago by jun66j5

  • Resolution set to duplicate
  • Status changed from new to closed

It seems to be a duplicate of #8188. And verified the fix for this issue.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from rjollos. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.