Modify

Opened 8 years ago

Closed 8 years ago

#793 closed defect (duplicate)

Registering a new User produces error - no such file or directory

Reported by: phillipsic@… Owned by: mgood
Priority: normal Component: AccountManagerPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.9

Description

Using Trac 0.9.6 Tried to register a new user Test/test and the following error was produced. I am able to login with existing users.

Here are the sections of my trac.ini file

components]
webadmin.* = enabled
acct_mgr.web_ui.registrationmodule = enabled
acct_mgr.web_ui.accountmodule = enabled
tracnav.* = enabled
trac.web.auth.loginmodule = disabled
acct_mgr.api.accountmanager = enabled
acct_mgr.web_ui.loginmodule = enabled
acct_mgr.htfile.htpasswdstore = enabled
acct_mgr.htfile.htdigeststore = enabled
acct_mgr.htfile.abstractpasswordfilestore = enabled
tractoc.macro.tractocmacro = disabled

[account-manager]
password_format = htpasswd
password_file = C:/trac/conf/svnAuthfile
Traceback (most recent call last):
  File "C:\Python23\Lib\site-packages\trac\web\cgi_frontend.py", line 130, in run
    dispatch_request(req.path_info, req, env)
  File "C:\Python23\Lib\site-packages\trac\web\main.py", line 139, in dispatch_request
    dispatcher.dispatch(req)
  File "C:\Python23\Lib\site-packages\trac\web\main.py", line 107, in dispatch
    resp = chosen_handler.process_request(req)
  File "build\bdist.win32\egg\acct_mgr\web_ui.py", line 117, in process_request
  File "build\bdist.win32\egg\acct_mgr\web_ui.py", line 150, in _do_create
  File "build\bdist.win32\egg\acct_mgr\api.py", line 88, in set_password
  File "build\bdist.win32\egg\acct_mgr\htfile.py", line 63, in set_password
  File "build\bdist.win32\egg\acct_mgr\htfile.py", line 152, in userline
  File "build\bdist.win32\egg\acct_mgr\htfile.py", line 125, in salt
  File "build\bdist.win32\egg\acct_mgr\htfile.py", line 43, in urandom
IOError: [Errno 2] No such file or directory: '/dev/urandom'

Attachments (0)

Change History (1)

comment:1 Changed 8 years ago by mgood

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #63.

Add Comment

Modify Ticket

Action
as closed The owner will remain mgood.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.