Modify

Opened 4 years ago

Last modified 3 years ago

#8102 new defect

Can't install plugin properly.

Reported by: kamillo1888 Owned by: hvr
Priority: high Component: GitPlugin
Severity: major Keywords:
Cc: Trac Release: 0.12

Description

I can't install git plugin - i have this message:

easy_install http://github.com/hvr/trac-git-plugin/tarball/master
Downloading http://github.com/hvr/trac-git-plugin/tarball/master
Processing master
Running hvr-trac-git-plugin-60cf7b8/setup.py -q bdist_egg --dist-dir /tmp/easy_install-vcnH3y/hvr-trac-git-plugin-60cf7b8/egg-dist-tmp-027SXU
  File "build/bdist.linux-x86_64/egg/tracext/git/PyGIT.py", line 106
    with self.__lock:
            ^
SyntaxError: invalid syntax
  File "build/bdist.linux-x86_64/egg/tracext/git/git_fs.py", line 567
    yield (self.path, rev, Changeset.EDIT if not is_last else Changeset.ADD)
                                           ^
SyntaxError: invalid syntax
zip_safe flag not set; analyzing archive contents...
TracGit 0.12.0.5dev is already the active version in easy-install.pth

Installed /usr/lib/python2.4/site-packages/TracGit-0.12.0.5dev-py2.4.egg
Processing dependencies for TracGit==0.12.0.5dev
Finished processing dependencies for TracGit==0.12.0.5dev

If I enabled git plugin in trac.ini file i had this error:

Warning: Can't synchronize with repository "(default)" (Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? ). Look in the Trac log for more information.

What was wrong? Is that bug?

Attachments (0)

Change History (4)

comment:1 follow-up: Changed 4 years ago by tfotherby

I got the same problem. I think it is caused because doing:

easy_install http://github.com/hvr/trac-git-plugin/tarball/master

is for when you have python v2.6, but from your logs it looks like you are using python v2.4? Try the 2.4 branch:

easy_install http://trac-hacks.org/svn/gitplugin/0.11-py2.4/

comment:2 Changed 4 years ago by sniperpr@…

i have same problem

asy_install http://github.com/hvr/trac-git-plugin/tarball/master
Downloading http://github.com/hvr/trac-git-plugin/tarball/master
Processing master
Running hvr-trac-git-plugin-60cf7b8/setup.py -q bdist_egg --dist-dir /tmp/easy_install-NYROf3/hvr-trac-git-plugin-60cf7b8/egg-dist-tmp-Z1P4dX
  File "build/bdist.linux-i686/egg/tracext/git/PyGIT.py", line 106
    with self.__lock:
            ^
SyntaxError: invalid syntax
  File "build/bdist.linux-i686/egg/tracext/git/git_fs.py", line 567
    yield (self.path, rev, Changeset.EDIT if not is_last else Changeset.ADD)
                                           ^
SyntaxError: invalid syntax
zip_safe flag not set; analyzing archive contents...
Removing TracGit 0.11.0.2 from easy-install.pth file
Adding TracGit 0.12.0.5dev to easy-install.pth file

Installed /usr/lib/python2.4/site-packages/TracGit-0.12.0.5dev-py2.4.egg
Processing dependencies for TracGit==0.12.0.5dev
Finished processing dependencies for TracGit==0.12.0.5dev

comment:3 in reply to: ↑ 1 Changed 3 years ago by anonymous

master branch does not work with python 2.4 I attempted to recode the "with" statements and new if syntax. It installed but trac does not recognize it.

Replying to tfotherby:

I got the same problem. I think it is caused because doing:

easy_install http://github.com/hvr/trac-git-plugin/tarball/master

is for when you have python v2.6, but from your logs it looks like you are using python v2.4? Try the 2.4 branch:

easy_install http://trac-hacks.org/svn/gitplugin/0.11-py2.4/

comment:4 Changed 3 years ago by anonymous

exactly the same problem here

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.