Modify

Opened 8 years ago

Closed 4 years ago

#830 closed defect (invalid)

All ticket hour reports fail with an error about an undefined variable '$NEW' NOT A BUG BUT LEFT HERE FOR REFERENCE.

Reported by: bugs@… Owned by: bobbysmith007
Priority: lowest Component: TimingAndEstimationPlugin
Severity: trivial Keywords:
Cc: Trac Release: 0.9

Description

I installed the trunk version from the zip file that you can download.
I can enter hours fine, but all reports fail with:

Report execution failed: Dynamic variable '$NEW' not defined.

Looking at the report, you use $NEW where the original trac report would just use 'new'.

I'm using trac 0.10.

Attachments (0)

Change History (8)

comment:1 Changed 8 years ago by bobbysmith007

  • Priority changed from normal to lowest
  • Severity changed from major to trivial
  • Summary changed from All ticket hour reports fail with an error about an undefined variable '$NEW' to All ticket hour reports fail with an error about an undefined variable '$NEW' NOT A BUG BUT LEFT HERE FOR REFERENCE

This is not an error, please see the user manual linked off of the billing and estimation page.

This message is received when you go to the report not from the billing and estimation page. In order to make these reports, there are variables that need to be passed on the query string.

Thanks,
Russ

comment:2 Changed 8 years ago by dmohr

Sorry for not RTFM. It's just non-obvious that the reports are not usable from the view tickets screen (even though I understand why they are - because you reused the trac structures). Thanks for the nice plugin, pretty useful!

comment:3 Changed 7 years ago by ruben.ortiz@…

  • Summary changed from All ticket hour reports fail with an error about an undefined variable '$NEW' NOT A BUG BUT LEFT HERE FOR REFERENCE to TimmingandEstimation Plugin not well installed

Hi

i have a same error. I follow step by step plugin installation guide and i installed for global projects with easy_install. But i see the same error like the first ticket. And i don't have the Billing Page ("Management") and the plugin is not show in Plugins list.

But i don't see any error in my Timeandestimation plugin installation. This was the python outpout:

trac-admin /var/lib/trac/trac upgrade
/usr/lib/python2.3/site-packages/trac/loader.py:96: UserWarning: Module timingandestimationplugin was already imported from /usr/lib/python2.3/site-packages/timingandestimationplugin-0.4.9-py2.3.egg/timingandestimationplugin/init.pyc, but /var/lib/trac/trac/plugins/timingandestimationplugin-0.4.9-py2.3.egg is being added to sys.path

egg.activate()

Done
Timing and Estimation needs an upgrade
Upgrading Database
Creating bill_date table
Creating report_version table
Upgrading report_version table to v4
Dropping report_version table
Upgrading reports
Upgrading fields
Upgrading usermanual
Done Upgrading
Upgrade done.

Someone can help me here?

Thanks

comment:4 Changed 7 years ago by anonymous

I hit this as well. Perhaps you could document it in the user interface as well?
I tried adding the text below to the description but it gets reproduced in the normal report too.

I hit a further problem, #2024. Trying to fix this caused serious problems, see that ticket.

== Please Note ==

This is a private report used by the TimingAndEstimationPlugin.[[BR]]
That is why you are seeing an error message below.

[/trac/myproject/Billing Click here] to view T&E reports.

comment:5 Changed 7 years ago by bobbysmith007

  • Summary changed from TimmingandEstimation Plugin not well installed to All ticket hour reports fail with an error about an undefined variable '$NEW' to All ticket hour reports fail with an error about an undefined variable '$NEW' NOT A BUG BUT LEFT HERE FOR REFERENCE.

I am not sure what the problem you are experiencing is , but it seems unrelated to this ticket. Please open a fresh ticket describing your error. (#2024 doesnt exist).

Please try reinstalling fresh as well, as there may have been a bug in the version you installed.

comment:6 Changed 7 years ago by bobbysmith007

  • Summary changed from All ticket hour reports fail with an error about an undefined variable '$NEW' to All ticket hour reports fail with an error about an undefined variable '$NEW' NOT A BUG BUT LEFT HERE FOR REFERENCE. to All ticket hour reports fail with an error about an undefined variable '$NEW' NOT A BUG BUT LEFT HERE FOR REFERENCE.

comment:7 Changed 7 years ago by bobbysmith007

This has changed in trac 11 due to the magic of output stream filters

comment:8 Changed 4 years ago by bobbysmith007

  • Resolution set to invalid
  • Status changed from new to closed

Hopefully this problem is solved and will not come up again...

If I get new open tickets about this, I will reopen.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from bobbysmith007. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.