Modify

Opened 4 years ago

Closed 21 months ago

Last modified 20 months ago

#8314 closed defect (fixed)

Plugin no longer works correctly when used with the wysiwyg plugin

Reported by: anonymous Owned by: bobbysmith007
Priority: normal Component: TimingAndEstimationPlugin
Severity: normal Keywords:
Cc: kmolnar@…, jun66j5, slevin@… Trac Release: 0.12

Description

Since the timing and estimation plugin was updated to put the 'Add hours to ticket' field just below the comment field (and above the 'Modify Ticket' section), the field becomes invisible when the wysiwyg comment editor is selected.

To reproduce: Install trac 0.12, with timing and estimation tools plugin for 0.12 (I am using an export from svn rev 9643), and wysiwyg plugin for 0.12 (I am using an export from svn rev 9251). Enable both plugins in a project. Now choose the "wysiwyg" radio button just below the "Add a comment" header. When selecting "wysiwyg", you should see the "Add hours to ticket" field and stopwatch disappear. Selecting "textarea" should make those fields re-appear.

Attachments (2)

Screenshot-TimingAndEstimateWithTextArea.png (17.4 KB) - added by kmolnar@… 4 years ago.
Screenshot of TimingAndEstimate Add Hours With TextArea
Screenshot-TimingAndEstimateWithWYSIWYG.png (16.4 KB) - added by kmolnar@… 4 years ago.
Screenshot of TimingAndEstimate Add Hours With WYSIWYG

Download all attachments as: .zip

Change History (15)

comment:1 Changed 4 years ago by rjollos

  • Component changed from EstimationToolsPlugin to TracWysiwygPlugin
  • Owner changed from hoessler to jun66j5

@reporter: A screen capture would be useful.

Looks like this should be assigned against the TracWysiwygPlugin.

comment:2 follow-up: Changed 4 years ago by kmolnar@…

  • Component changed from TracWysiwygPlugin to TimingAndEstimationPlugin
  • Owner changed from jun66j5 to bobbysmith007
  • Type changed from defect to enhancement

I second this bug. Based on looking at how the WYSIWYG plugin works it seems to me that this needs to be changed on the TimingAndEstimation Plugin side. It is because the WYSIWYG plugin "disables" the div that contains the original text box which has the Add Hours attached to it and "enables" an other div that contains the WYSIWYG editor text box. Because of this the Add Hours entry fields are not visible. So it seems that the only solution is to separate the Comment text box and the Add hours fields hence the WYSIWYG operation will have no effects on it.

I'm attaching the requested screen shots.

Also, there is something funky going with the TicketPropsLayoutChanger as described here: http://trac-hacks.org/ticket/8274

Changed 4 years ago by kmolnar@…

Screenshot of TimingAndEstimate Add Hours With TextArea

Changed 4 years ago by kmolnar@…

Screenshot of TimingAndEstimate Add Hours With WYSIWYG

comment:3 Changed 4 years ago by anonymous

  • Cc kmolnar@… added; anonymous removed

comment:4 in reply to: ↑ 2 Changed 4 years ago by bobbysmith007

  • Cc jun66j5 added

Replying to kmolnar@virtualorgs.com:

I second this bug. Based on looking at how the WYSIWYG plugin works it seems to me that this needs to be changed on the TimingAndEstimation Plugin side. It is because the WYSIWYG plugin "disables" the div that contains the original text box which has the Add Hours attached to it and "enables" an other div that contains the WYSIWYG editor text box. Because of this the Add Hours entry fields are not visible. So it seems that the only solution is to separate the Comment text box and the Add hours fields hence the WYSIWYG operation will have no effects on it.

Alternatively WYSIWYG, could not replace the entire div, but the textarea itself. It seems that this would interfere much less with every other plugin (not just TimingAndEstimationPlugin). That said, I will try to append this field elsewhere, so that T&E is no longer blamable.

comment:5 Changed 4 years ago by bobbysmith007

  • Resolution set to fixed
  • Status changed from new to closed

(In [9973]) Changed where the add-hours field is being moved to (not visibly) to increase interoperability ver 1.1.1 fix #8314

comment:6 Changed 4 years ago by kmolnar@…

Tested with the 1.1.1 version and the problem is gone. Thank you very much for the prompt response and fix.

comment:7 Changed 4 years ago by bobbysmith007

Your welcome, glad to be of assistance :)

comment:8 follow-up: Changed 3 years ago by slevin@…

  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Type changed from enhancement to defect

That problem - T&E conflict with TracWysiwygPlugin retback again. For me from T&E v.1.2.4 and Trac 0.12.2. When in T&E plugin config I set to true checkbox "TimingEstimationAndBillingPage" - I can't use TracWysiwygPlugin when create new ticket in that trac. In that situation we're can't edit via TracWysiwygPlugin ticket's body. :(

comment:9 Changed 3 years ago by slevin@…

sorry - I forgot one thing: also that problem stotred till v.1.2.7 T&E plugin (till current version).

comment:10 in reply to: ↑ 8 Changed 3 years ago by bobbysmith007

  • Cc slevin@… added

With T&E disabled Wysiwyg seems to work but throws many javascript errors like:

uncaught exception: TypeError: event.originalTarget.getElementsByTagName is not a function
[Break On This Error] 	
return this.contentDocument.execCommand(name, false, arg); wysiwyg.js (line 569)


uncaught exception: TypeError: event.originalTarget.getElementsByTagName is not a function

The bug I am capable of reproducing comes about when enabling TicketPropsLayoutChanger. This component is not vital and can safely be turned off. (It simply tries to remove some empty rows that occasionally show up in the ticket properties.

When enabled that component prevents the wysiwyg box from being enabled for typing, though why I am not sure. Please try disabling TicketPropsLayoutChanger and verify that everything works as you would expect. Not sure what to do about this as I have had little luck figuring out what is causing the problem.

comment:11 Changed 3 years ago by slevin@…

It's works for me, thank you sir!

comment:12 Changed 21 months ago by bobbysmith007

  • Resolution set to fixed
  • Status changed from reopened to closed

I guess resolving this as fixed. It would be swell if someone posted a patch that didnt require removing one of the components for these to be compatible, but honestly this is such a non priority for me that I doubt I will ever accomplish this.

comment:13 Changed 20 months ago by bobbysmith007

I changed all the layout changing javascript in #10977, perhaps this problem is solved now?

Add Comment

Modify Ticket

Action
as closed The owner will remain bobbysmith007.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.