Modify

Opened 3 years ago

Closed 21 months ago

#8450 closed defect (duplicate)

Upgrade Error question?

Reported by: miraqidev@… Owned by: coling
Priority: normal Component: ClientsPlugin
Severity: major Keywords:
Cc: Trac Release: 0.12

Description (last modified by rjollos)

Hi
When I run the upgrade after enabling the plugin I get the following error

ClientsPlugin needs an upgrade
 * Upgrading db
Creating client table
WorklogPlugin Exception: table client already exists
 * Upgrading reports
UnboundLocalError: local variable 'version' referenced before assignment

I have corrected the typo in reportmanager.py as noted in the Recent Changes section(9713).

Please Help.
Thanks.

Attachments (0)

Change History (3)

comment:1 Changed 3 years ago by rjollos

  • Description modified (diff)

comment:2 Changed 2 years ago by yamilchamut@…

I was having the same problem, but I managed to solve it by adding "global version" between lines 21 and 23 on reportmanager.py

Hope it helps!

Y.

comment:3 Changed 21 months ago by rjollos

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #7450. See that ticket for solution.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from coling. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.