Modify

Opened 3 years ago

Closed 3 years ago

#8769 closed defect (worksforme)

disabling default handler prevents login

Reported by: anonymous Owned by: rjollos
Priority: normal Component: TagsPlugin
Severity: normal Keywords: default handler
Cc: support@…, hasienda Trac Release: 0.11

Description (last modified by rjollos)

From the install :

"In particular trac.wiki.web_ui.wikimodule = disabled and default_handler = TagsWikiModule must be removed"

When doing this , Trac presents an internal error stating that :

"AttributeError: Cannot find an implementation of the "IRequestHandler" interface named "WikiModule".  Please update the option trac.default_handler in trac.ini.
There was an internal error in Trac. It is recommended that you notify your local Trac administrator with the information needed to reproduce the issue.

So I undid those recommendations again and the trac error is gone.

Attachments (0)

Change History (3)

comment:1 Changed 3 years ago by rjollos

  • Description modified (diff)

comment:2 Changed 3 years ago by rjollos

  • Cc hasienda added
  • Owner changed from otaku42 to rjollos
  • Status changed from new to assigned

The wiki page for the TagsPlugin states:

Be sure to remove any previous TagsPlugin configuration changes. In particular trac.wiki.web_ui.wikimodule = disabled and default_handler = TagsWikiModule must be removed. 

Okay, it sounds like this is speaking to an upgrade from a previous version of TagsPlugin (0.5 or ealier) to version 0.6. Are you in fact upgrading? If not, I think you can safely ignore this step.

Perhaps we can improve the wiki documentation slightly though so that others don't get confused.

comment:3 Changed 3 years ago by rjollos

  • Resolution set to worksforme
  • Status changed from assigned to closed

Closing since there was no response. Please reopen if you continue to experience the issue with the latest version of the trunk.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from rjollos. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.